Gentoo KDE mouse not working

so when after much annyoing times with gnome on debian and screen tearing in kde on debian lol i decide to install gentoo cause i have never used it before and i dont hear so much bad things about it execpt that the compiles times takes forever and well compiling takes time but anyway i have installed kde and when i get to KDM my keyboard works and i can log in but my mouse dont work in kdm or when logged in to kde.... i have actually no idea i have used google but i dont really find someone with the same problem? or maybe just me that is stupid idk hehe

Did you build a module for your mouse (write a makefile) and load it into your kernel?

If the answer is "no," then Gentoo is probably not the right distro for you, and something simple like Archlinux would probably be a logical alternative.

well yeah i did think on archlinux but when it didnt worked to boot with rufus(syslinux) i was abit lazy and i had gentoo that worked ... so haha and well i installed kernel with genkernel for lazyiness is it already mouse kernel module or something? and well haha i am gentoo noob first time dont kill me ;3 lol but i mean i have nothing against to learn things so i prefer to just stick with it instead of something like arch cause i guess gentoo works really well with everything setup?:)

Gentoo will work better than almost anything ONLY when you configure it properly. Optimising the kernel and choosing to install all programs from source is essential to achieve a truly refined Gentoo installation. It often takes many attempts to learn all the intricacies of Gentoo (especially with the Linux kernel) before anything is efficiently and effectively optimised.

is you too saying i should install something else ;( haha i go install ubuntu then.....  lol :P


No stick with it. Gentoo is hard, but it's worth it. Perseverance is key to have success with such a "advanced" Linux distribution (relative to Ubuntu for example).

hehe im still not sure about the mouse tho... do i need to make a own kernel module with genkernel? or what he meant

What type of mouse? If you go the kernel route, all it requires is ticking a module, compiling and installing it and it should work. But if the problem is not kernel-related, it might be X. If you can get into the X test environment, you should test your mouse there. If it doesn't work then it's probably a lacking kernel module.

well its a mionix usb mouse.. i saw many talked about evdev driver.. so i enabled but i dont think it work i will just read ALL of the gentoo wiki and come back if i really cant fix it hehe :) well thanks anyway

so now i have actually fixed the mouse problem and im quite sure it was kernel module that wasnt loaded hehe cause i recompiled a kernel with all usb things and it worked on next reboot :)

Good job.

Persitence is key when using Gentoo.