Gentoo build problems

Hey guys
So i am doing a manual kernel configuration on gentoo
I built the system in hyper v. Everything works good, I guess. The system boots and loads everything. Except I have one issue: I have not networking. I can not find my eth0, the only network device it finds is lo

I have tried adding LITERALLY every single network driver and it doesnt work
I loaded up the hyper v modules for the kernel

weird thing

lspci shows no ethernet/network controller

I am lost, and I need networking to do things. I have been using google for HOURS and havent found anything that has helped.

1 Like

Having a quick google, some old posts suggest that hyper v requires you enable legacy networking in the kernel. im not sure if this is still the case but try that if you haven't already.

I did this and no luck. I did however get the ethernet controller to show up in lspci but i still cant get it to load eth0 up. I have the drivers for the controller installed in the kernel.


You said that you have enabled the kernel module for Hyper-V networking. Are you sure that the kernel module is actually being loaded by either the OpenRC init system or manually using modprobe?

have you tried to configure /etc/network/interfaces

Even without configuration in /etc/network/interfaces the NIC should appear using the ifconfig command.

I fixed it, I forgot to enable another Hyper V module setting and once I did that everything worked. Dont forget your hyper v modules!!

Manual kernel configuration is nice and very customizable but you have to take all these things in to account. Glad you have gotten it working though.

Good luck with Gentoo.

1 Like