Return to Level1Techs.com

Gaming on linux


#1

Hello! I currently have ubuntu 18.04 installed with vulkan, wine 4.0 r7 with lutris installed. Also graphics card driver 415 through nvidia. I have a I7-8700 with 16gb of ram and a gtx 1080. I have starcraft 2 installed and running but the FPS is cut in almost half of what i would run on windows. When on windows on extreme settings ill get about 115fps. On ubuntu ill get 60 but drops as the game goes on to 30 or 25 fps. I do not get the fps drops on windows. I also enabled Csmt.


#2

I didn’t see an actual question in the OP, only a series of statements.

As you have discovered, performance vs. windows may differ when running games originally published for Windows via emulation.

Things likely will get better with time, some games may work better than others. Games that run as well or better than in Windows are few and far beween at the moment.


#3

Sorry about that. I just wasent sure if theres something i needed to do to get more performance out of it or not.


#4

Sounds to me you don’t have some setting set up right, as to what that setting might be I wouldn’t know. You don’t have G-Sync enabled do you? I don’t know for sure but I think G-Sync like FreeSync isn’t supported in Linux yet?


#5

If you have multiple monitors, verify both are running at their rated Hz if you have any kind of v-sync.

If you can, try running it in windowed mode and see if it performs any better


#6

G-Sync is supported with the proprietary Nvidia driver.


#7

No gsync i dont have a compatible monitor


#8

Both work on linux. Got to jump through some hoops to get either working though.


#9

Gsync worked for me without the need to jump anywhere. NVIDIA driver needs to be installed and it can be a bit annoying to get it to persist the settings on reboot. But otherwise everything worked fine for me as far as gsync is concerned. I believe gsync was on by default after installing the driver.


#10

If the game is DX11, make sure you’re using DXVK rather than the default WineD3D. WineD3D maps D3D calls to OGL and is much slower than DXVK which maps onto Vulkan.


#11

When using Lutris you should add some NVidia variables to it like …

__GL_THREADED_OPTIMIZATIONS=1
__GL_SHADER_DISK_CACHE=1
__GL_SHADER_DISK_CACHE_PATH=$HOME
__PBA_GEO_HEAP=7999
PBA_DISABLE=0

#12

Im sure its a easy answer but how can i make for certain that its using vulkan rather than wine3d3


#13

It seems like SC2 is DX9 only, which is why performance is poor. DXVK only works for DX11.


#14

Go into Lutris settings for the game and choose a DXVK version. 0.96 is the latest one.