Return to Level1Techs.com

G-Sync Gaming Notebook GPU Passthrough

#1

Hey, guys,
I think I managed to get through my GTX 1070M,
but I have problems installing the NVIDIA driver on my Windows guest.
NVIDIA Driver Installer simply throws “This NVIDIA graphics driver is not compatible with this version of Windows” during installation.

GPU-Z shows the correct model GP104, but as Microsoft Basic Display Adapter.
Since I use a GSYNC laptop, my laptop has disabled its iGPU and I find it strange that I actually get a screen output, but nvidia and windows don’t recognize the GPU.

Used this git as a guide, to set everything up.: https://gitlab.com/YuriAlek/vfio
Switched from OVMF to SeaBIOS just because my GPU-VBIOS is not UEFI.
I hope you guys can help me :).

An Image of my Problem:

0 Likes

#2

you using regular or dch drivers

1 Like

#3

Regular

Edit: tried DCH doesnt work either, same thing

0 Likes

#4

did you try passing a modded vbios

1 Like

#5

Nope, I extracted mine on Dual Boot Windows, copied it to Linux Host, fixed the HEX and passed that through.
Do you mean modded in terms of UEFI btw.?
I also tried and contacted ASUS but they said they wouldnt hand out UEFI VBIOS for my GPU

0 Likes

#6

do you have hidden mode and a device id/ioapic fixes in your xml?

1 Like

#7

I am using qemu from CLI with script, i guess you mean kvm=off and hv_vendorid which i do use even tho i never even got to code 43.

0 Likes

#8

is there an optimus/hybrid mode in the bios or is it strictly gsync

if not you’re probably high and dry, only MXM muxed optimus laptops work most of the time to my knowledge

1 Like

#9

strictly GSYNC I think, never found an option for it.
It is the ASUS G752VSK btw.

0 Likes

#10

you could try passing a modded gp104 vbios with the appropriate amount of sms turned off and the same memory chips, but it’s squirrely and totally uncharted territory at that point.

1 Like

#11

Do you mean I should download a Desktop or Mobile GPU VBIOS with simliar stats to mine and mod it down?
I have now also tried GOPUpd with OVMF and got exactly same error and GPU-Z results.

0 Likes

#12

's just speculation on my part, no one’s confirmed a gsync laptop or a muxless optimus to work yet to my knowledge.

might as well try both if you’re willing to go that far.

1 Like

#13

Do you know any way to debug to see what happened if vm didnt run with the VBIOS.
Like what the VBIOS should have or not have?
I am really willing to try hard on this one as i would love to have that Notebook only as a host of multiple VMs.

Edit:
What i have seen most was just the VM didnt boot up showing me a blackscreen and never return to my host until restart.
This is really painful todo since I also have to decrypt my disk with a long pass at boot xD

0 Likes

#14

id guess just parse the libvirt logs for rombar stuff, not really a domain expert on untested laptop configs myself.

try posting on /r/vfio about it

1 Like