Frozen black screen on boot with Kubuntu 20.04 andAMD RX 580

Hi !

I have some issue with kubuntu and my AMD RX 580. I have a dual boot windows / linux. On windows, the AMD drivers are installed, the RX 580 performs just fine.

Linux: Distro: Kubuntu 20.04, kernel: 5.4 (also installed 5.5.0 rc5 in trying to find a solution).

The problem: starting the system results in a black screen with a “glitched” colorful horizontal line near the bottom. If I wait a while, the GPU’s fans start spinning at full speed for maybe 10 seconds, then stop, and nothing more happens. Impossible to switch to a console, I have not control here.

I can boot in low-res by adding “nomodeset” to the kernel boot parameters. I tried to install the proprietary drivers, alternatively amdgpu and amdgpu-pro (amdgpu-pro-20.20-1098277-ubuntu-20.04.tar.xz). The problem was not solved, so I removed them.

I removed “quiet splash” from /etc/default/grub. The problem was still there, but with some text diplay before the freeze, the last line being:“fb0: switching to amdgpudrmfb from EFI”
This got me to this post “b0-switching-to-amdgpudrmfb-from-efi-vga” (same forum, somehow I cannot insert the link in my post), but even trying the stuff mentioned there did not solved my problem: installing 5.5.0rc5 kernel and updating the open-source drivers with ppa:oibaf/graphics-drivers. With the new kernel, I got a different error message “MODSIGN: Couldn’t get UEFI db list Couldn’t get size: 0x800000000000000e” I dealt with by adding “noapic noacpi nosplash”. This simply reverted to the previous error message “fb0 …”

I tried other boot parameters: “pci=noats”, and “amdgpu.dc=0”. This did not solve the problem.

I purged the oibaf ppa to get back to the original state, I don’t really know what to do from here. Any help troobleshooting this would be greatly appreciated.

Best, BC.

Hm… This quite strange.

  1. 5.5.0-rc5 is an old version of the kernel. You can get the latest one from here if you wish to test the system with the latest mainline kernel. You can also use a script for this. I suggest avoiding the release candidates (-rc) if you’re not overly adventurous (I use the mainline kernel builds on my laptop and they work quite well).
  2. Without doing any modifications to the kernel command line (boot options/parameters) other than removing quiet splash, could you take a landscape photograph of your display when the error occurs? This might be related to a line before the latest one in the TTY output (yes, it displays things on TTY1 when booting and the desktop environment is usually on TTY1 as well), which is the only one which you mentioned.
  3. If you can boot with nomodeset, could you try booting without nomodeset, encounter the error, reboot with nomodeset, and run journalctl --catalog --boot=-1 after booting to see the systemD journal from the previous (error) boot, assuming that it managed to record anything in the journal before the error that is? You navigate in the journal just like you navigate in Vim (Shift+G to get to the bottom of the journal for example).

I wish you a nice day.

1 Like

Ah right, I installed v5.8.14 of the kernel. Same situation.
Here is the photo of booting without “quiet splash”.

I looked into `journalctl --catalog --boot=-1 | tail -1000; but I think the last things are from my last successful boot with nomodset. Above are thousands of lines, I don’t really know how to sort this.

Thanks for helping !