Fresh Ubuntu 20.04.4 Install Won't Boot On Supermicro M12SWA-TF Motherboard (Threadripper Pro - WRX80 Chipset)

I’m here because of something that was said in a L1Techs Youtube video about the ASUS Pro WS WRX80E-SAGE SE WIFI motherboard. I believe I am having the exact problem described in the Level1Techs youtube video titled “Threadripper Pro: First Look at the ASUS Pro WS WRX80E-SAGE SE WIFI + 32 Core TR Pro 3975WX” at time 2:48. If I had an ASUS motherboard instead of a Supermicro motherboard, I would know exactly what to do, and I would probably have a working linux install right now. Alas, I have the Stupourmicro board, and I can’t boot into GRUB. I have set my motherboard’s firmware to prefer offboard VGA. Below is a copy of a post I made on Ask Ubuntu about this same problem.

I can’t seem to get my fresh Ubuntu 20.04.4 install to boot up. I have gotten the Windows 10 install usb stick to boot, and install windows, and I’ve booted up a fresh install of Win 10. I’ve gotten an Arch install .iso to boot up via usb, and the Ubuntu-Server 20.04.3 install .iso to boot up via usb, and the Ubuntu-Desktop 20.04.4 install .iso to boot up, but only in safe graphics mode, via usb. I have read that there may be some problems with native graphics support for my video card, and separately, that there may be some graphics conflict caused by my WRX80 motherboard’s firmware. So far, the only Linux GUI that I’ve been able to boot has been the Ubuntu-Desktop install .iso, in safe graphics mode, via usb. It seems that Windows automatically boots in some kind of safe graphics mode.

I would think that my problem is graphics related, but my Ubuntu installs don’t even make it to the GRUB bootloading screen. Something is happening that prevents GRUB from loading or displaying, all I get is the Supermicro splash screen forever (I’ve let it go for half an hour). Any help would be greatly appreciated, thanks, I’d be glad to supply any boot logs or config files or whatever. My motherboard is running the latest firmware, 1.0c.

Here is my hardware:

  • Corsair AXi Series, AX1600i PSU
  • Supermicro M12SWA-TF Motherboard
  • AMD Ryzen Threadripper Pro 3975WX
  • Supermicro (Samsung) 64GB 288-Pin DDR4 3200 (PC4-25600) Server Memory (MEM-DR464MC-ER32)
  • MSI Mech Radeon RX6700 XT 12GB
  • LSI Broadcom SAS 9300-8i 8-port 12Gb/s HBA
  • 12 of Seagate Exos X18 18TB Enterprise HDD
  • 3 of Team Group T-FORCE CARDEA Z44L M.2 2280 1TB PCIe Gen4 x4, NVMe 1.4

I don’t have that kind of hardware so I am unable to speak directly to it, but here are some thoughts on things that you might be able to try:

  1. According to the Supermicro website for your motherboard, it says that it has IPMI that’s shared with the GbE NIC port, so one thought would be to see if you might be able to install the system with that. (I don’t know if it would really make a difference, but I suppose that it can’t hurt to try.)

  2. Because it has onboard IPMI, the other thing that you might try as well would be to see if you can remove your video card from your system, and go through the installation process with just the IPMI onboard video/frame buffer.

The thought behind that is if you can get the base system up and running without a video card, then maybe you might be able to install updated drivers for your video card and then try popping your video card back in to see if that might make a difference.

If that works for you, then the issue was with the video card.

If it still doesn’t work for you, then I’m not really sure what the issue is.

There is a potential that if your system works with the onboard IPMI framebuffer, but NOT your RX6700, then depending on what is the version of the kernel that ships with a fresh install of Ubuntu 20.04.4, you can try updating your kernel along with the updated video card drivers to see if the combination of the two can help get your system up and running.

  1. The third thing that I would check would probably be the UEFI/CSM boot options in your motherboard BIOS.

Some motherboards might have an option for like “non-Windows UEFI” or something like that.

Maybe try that and see if any of those options works for you.


1 Like

I have similar hardware…


AMD Ryzen Threadripper PRO 3955WX

64GB DDR4-3200 RAM


RX 6900 XT

Created this account just to respond to you. :slight_smile: I hit some snags along the getting my system up and running. I got my system recently from Microcenter as an Open box item.

Have you updated your “bios” (actually UEFI) and BMC to the latest on the SM website? Easiest way is through the BMC/IPMI. The password is on a sticker on the board if you’ve never seen it before.

I successfully installed the “daily” build of Focal desktop today.

The 5.15 kernel seems to have issues based on the kernel OOPS / BUG.

  • 10 gig adapter
  • MBs DMA

one snag might be that this system only boots UEFI, AFAIK there’s no BIOS emulation, a Supermicro FAQ hinted at this.

I’m not sure if this will fix your issue, but here’s what I did to get it running.

  • Setup serial console and connected from another machine.
  • Connected a monitor to the VGA on the MB
  • Updated firmware for BMC and BIOS/UEFI (did not preserve anything when prompted) via BMC.
  • Verify updates applied. Unplug all external connections.
  • Removed all add on cards including GPU (BMC has a video device)
  • Corrected DIMM install order. (Was exactly opposite for 4/8 dimms)
  • Corrected 8 pin (cpu/mb) power tail installation per MB manual. It’s now the two top 8pin & 24 pin. If you have three 8 pin cpu power tails, you can install all three. Note that PCIe and CPU connectors are not interchangeable without adapters.
  • Reset CMOS
  • Disabled 10 gig adapter (some kernels had were dumping stacks in this driver)
  • Disabled UEFI Graphical boot screen
  • SM FAQ suggested In setup, disabled io-mmu and …(ADC?)
  • Booted focal daily build from USB and installed via VGA.
    • I’d be nice to have a image that already has the serial console stuff setup…
  • Setup serial console for grub, kernel and systemd to get an idea what’s happening.
  • Apply grub changes
  • Shutdown and unplug
  • Install GPU, I needed 3 8-pin PCIe
  • Set “output” to external graphics
  • Disconnect VGA
  • I had issues getting the HDMI port working, but display port worked.
  • Don’t install the HWE kernels (if you do, you can switch back at grub prompt)

Sorry if this is unorganized, I was just try to give you the key points without writing a novel.

1 Like