FreeSync won't enable Please help

No matter what I do freesync will not enable. Its enabled through the catalyst and on the monitor but will not let me turn it on in the demo. If anyone has any idea what is going on please let me know.

amd 15.8.1 beta
r9 295 x2
washabi mango 42 inch 4k

I dident think FreeSync worked on Crossfire cards anless thay fixed it?
A r9 295 x2 is 290 crossfire

Newest update enables FreeSync with Crossfire.

Same thing here with crossfire R9 290s, but freesync is actually enabled. Open CCC, enable freesync, look at the test pattern. Then just disable it in CCC while the test is running, you'll immediately see the difference. It's probably an issue with the windmill demo, freesync is definitely working in my case.

I'll try that and check it out. While i'm here if anyone has had any experience with the washabi mango 42 4k. I need some help on that. I have some horrible ghosting. basically when i turn there is an after image that is very clear. Anyone know a setting or anything that may need to be disabled to help improve that?

I'm absolutely sure that this is the case, disable V-sync in the demo and look at the test pattern (with CCC open), you'll see no tearing. As soon as you disable freesync in CCC you'll immediately see all that tearing, it's very obvious. The freesync switch in the demo doesn't do anything, that is the only problem here.
Can't help you with that monitor though, good luck on that and maybe make a new topic when it is a specific issue that is not related to freesync (although some monitor have issues with overdrive while freesync is enabled, that's why my BenQ needed a firmware update). Maybe try disabling freesync and see if the ghosting changes and check overdrive/AMA settings.

You need to use Display Port for the monitor you wonna freesync. You using DP? Cant tell from the pictures.