FreeNAS, Windows clients can't login to cifs shares


By now I feel pretty stupid, but all I was able to google up did not solve my problem.
I have a FreeNAS box which is pretty much running like a charm, but as I use linux for my workstations I did not realize yet, that I actually can not authenticate to shares using windows (7/10).

I have no domain, but user+password; Under Linux it works great, giving usernam + password lets me access the CIFS (smb) share(s) but when I use the same username and password under Windows - nope - it tells me (in German) that I have no autorisation to access the Networking resource.. but why?

On the FreeNAS I use windows permissions for the datasets and as said, connecting from a linux machine it works like expected.

Have you tried host/user for the user login? it may be host\user I can't remember. Or use the hostname of the server as the domain name when authenticating.

1 Like

ok I tried now

WORKGROUP\user - as I do not have a AD

storage-01\user - hostname of the box

storage\user - dns name of the box

with its password - the same error comes - funny thing is, that the anonymous fileshare works; so accessing the NAS without username/password works from windows as well.

You need to give read permissions on the root of WORKGROUP storage-01

Then make sure that only the user has drwx and nothing else on the user directory. Here's a little help if you haven't looked at it yet:

1 Like