FreeNAS coral Released - formerly FreeNAS 10

Surprised nobody here is talking about it. I need to setup a test box and give it a test drive.

STH article about it here as well:


I've been on the BETA for about a month in preparation. The NAS functionality seems to be solid but I'm just a home user so I don't do as much with it as someone who would be using it for a business solution. There is a learning curve if you haven't used docker before. Most of the containers take a little bit more effort for the user to setup than the jails did in my opinion. That's the trade off I suppose. The docker containers are easier for the developers to make and there are thousands already available. But the user has to put more thought into setting everything up. You'll have to setup the docker VM and allocated resources based on your own hardware unlike the jails that had access to all the system resources. This is supposed to help prevent a runaway plugin from eating up all the system resources and crashing the system. Many of the containers that I have installed also have more setup requirements that need to be planned out before installation, like networking type and places to store configuration files separate from the VM file system. It's not just a push button install like the plugin jails were. All this stuff had to be done with the jails as well but it could usually be done after the plugin was installed.

1 Like


Updating my Freenas 9.10.2 box over to Coral, will give first impressions when its done and I've had a bit to play around with it.

1 Like

Also updating, I have a few hours before night shift.

Not sure what will happen to all the jails, I don't think there is an upgrade path for them. I guess I will just find the corresponding docker images, and run the rest in iohyve environments. Docker images exist for all the standard PVR stuff, unsure about print servers for my old laser printer.

Might also add a cache SSD, since this is handled in the interface now and is a bit more intuitive. Not sure what stopped me before, I think i got confused about errors creeping in. SSDs are not immune to bitrot.

Taking a while to import pools and upgrade from 9.10, hope it hasn't bombed out.

Restarted the installation and the migration seemed to complete this time.
Had to tweak the network settings, the network interface was not pulling the DNS and gateway settings from the DHCP server, so no internets for FreeNAS.

Resolved the boot2docker thing, it seems I didn't have any VM templates installed. Once they were downloaded (I somehow forced it be clearing the cache and or manually adding the github link), I can start installing docker images and get them running.

Like others mentioned below, I can get most things working by setting each container to bridged mode, and specifying a manual IP out of my DHCP range, sort of like the old jails.

Confirm UPS is connected and working. My exact model isn't listed, but similar ones are.
Look into syncthing again.
Add another SSD for cache.

Ideally, I should have done a fresh install. However, the upgrade seems to have ignored most of my rubbish and set half the stuff up correctly.

1 Like

I'm probably going to install this on my dual xeon which is basically a server now. I was going for debian 9 but since I haven't done that yet, I might try this out instead.

1 Like

Well - after upgrade - I am stuck at winbind trying to start - and samba is complaining about its config, very pleasant experience I have to say........

I always just plan on a fresh install with a major version upgrade. Detach and reattach the storage.

This version is a major change.


About to rebuild my Plex machine at home from 9.3 to Corral and I've had some problems with the installation so far but most of the issues have been with my flash memory and motherboard running on outdated bios. Would love to see someone run tests with Ryzen and the FreeNAS VM hosting.

I upgraded my home server to Corral Wednesday evening. I went from virtualized FreeNAS 9.10 on ESXi to running Corral on the bare metal because I was having issues with the Mellanox 10gb ethernet cards not passing through ESXi properly.

Current thoughts on initial setup:

The 10gb ethernet card works fine out of the box. Everything setup fairly easily in the GUI, though I had and still have some weird permissions issues with my SMB shares. I imported my old ZFS RaidZ2 pool of 8x2TB drives just fine and upgraded it to the new ZFS version. The new UI is very nice, much better than 9.x.

Docker and VM support:

Still having issues getting a Plex docker image working, the I seem to be unable to create a "host network" when setting up the Docker host. I'm probably doing something wrong, but I'm not sure what at the moment as I can't find any documentation on the various settings.

I also setup a Windows 10 VM so I can use the server's CPUs for Handbrake encodes, but currently after the install I seem to only have 2 cpu cores visible to the VM(in Task Manager) despite assigning all 16 available logical processors to the VM(2x 4 core Xeons with hyperthreading). Also the VGA console has terrible mouse mapping in the browser and is only slightly better in a VNC client. I was barely able to get Windows installed and enable Remote Desktop.

10gb Network Speeds w/SMB:

10gb ethernet speeds with SMB between FreeNAS and my Windows 10 desktop are kind of all over the place. With smaller files transfers in both directions are very fast when using an SSD on both ends. I was able to hit 450 MBps between SSDs both directions. I was able to pull 200-300MBps from my array of spinning rust, but for some reason it would slow down to ~120MBps after 10GB or so. Copying files to the NAS had similar results. I wasn't pegging the CPU in either case. The server has a pair of Xeon x5687s and 48gb of ECC RAM.

Current conclusions:

If the VM/Docker support doesn't improve I'll probably be looking into switching to ZFS on Linux, probably with Fedora or Centos. I also may look into Proxmox as a VM host and try virtualizing FreeNAS Corral as I do like the UI.

I don't know your network setup but I used Bridged mode with Plex, transmission, and subsonic with no issues. This duplicated the plugin jail settings I used on 9.10. I have a pfsense box with the static ip's and mac addresses already saved so I just copied them to the docker containers during setup.

Well I took a another crack at getting a Plex Docker container working and got it figured out. It's not very good at telling you which settings are wrong, so I was having trouble figuring out where it was breaking. Also since I don't have a Pfsense box at the moment(was virtualizing it on ESXi) I'm stuck with DHCP for the most part since I'm using my Netgear router.

Also it was well into the early hours of Thursday morning when I was working on it the other day so there is the tired factor to consider. ;-)

I'll just go ahead and report back my experiences.

So, ugh. I initially did a fresh install and tried to migrate my disks over. Nothing, would work right. The web panel was laggy as hell, the services didn't work right, and I couldn't get my network shares to appear. It was a shit show.

Okay, attempt two.

This time around I thought I'd upgrade my existing 9.10.2 install which I still had on a different USB. So, that was better. It had some bugs still, so I thought I'd try yet another fresh install on a different USB.

Try three.

Using a new USB this time, different to either the first or second try. Used the same install media as I did for the first initial install, and now it works great. Not quite sure why it didn't work right the first time, especially since I used a superior usb thumbdrive for the first install. Now that it's working right, I like it. I've got my shares working now, and I'm working on setting up some VM's to play with. I haven't been able to get a windows vm working quite right yet, not really sure why.


Now after leaving the system idle and coming back to it, I'm noticing much higher cpu utilization than I was used to observing on 9.10.2. Don't know if that's just differences in monitor or actually more tasks going on at iidle on 10 compared to 9.10.2. The system is an 8350 with 8GB ram for reference.


Right of the start - I have a debian VM now in FreeNAS10, is there a way to increase its disk size or add another disk device? - so far my googeling wasn't all to successfull

When I worked with the beta on bare metal a few times I found running it from an SSD helped with UI lag and such but doesn't fix all of it. Even though it is out if beta I believe they still have work to do with UI optimization.

Still got issues with containers. Can't download the templates.

Anyone with a pFsense box got any advice? I've tried NAT and Bridged mode with and without DHCP.

we are currently discussion the issues with SMB in this thread

Its running pretty quick on my third install now. I've got it on a Sandisk Cruiser 8GB Flashdrive plugged in via USB 3.0.

1 Like

Your freenas box has no internet at all?
Check the network tab, under settings and make sure assign gateway and dns are ticked. That did it for me.

1 Like

I don't have Pfsense right now, but here are my network settings that are working. Ignore the 192.168.1.x network; that's just for the direct 10gbe connection to my desktop.It doesn't carry any internet traffic.

Network Adapter Settings

Docker and VM Settings

Anyway figured this might be useful to someone.

1 Like