FreeNas 9.3 and E-mail service

I built a small FreeNas server for my home, I then configured a 16GB memory stick as a boot drive.
I inserted the memory stick into the computer and rebooted it, the server came up fine.
I then went into my desktop machine and typed in the http: location of the server, then entered the
username and password and was able to see the server fine.
I started to configure the NAS server using the Wizard and everything was moving along well until
I tried to set up e-mail notification and then I hit a wall!

The address I want to sent emails to is a G-Mail account, I entered the address along with ticking the box for
"Console Messages" form, then from "E-Mail Address" I used the standard [email protected]
I believe the issue is relating to Outgoing mail server, I had used smtp.gmail.com with Port 465 then selected SSL
turned on Use SMTP Authentication.
I then entered again my G-Mail user account with the passwords used for it.

It did not work, I tried many different configurations, I spent over two hours or so trying to fix this with the help of Mr. Google but I am stuck.
I believe the problem has to be with the Outgoing mail server, however I could be off base. I therefor am asking some one to give me a jump start, it would be greatly appreciated.

Best Regards

Have you tried using port 587?

Also have you tried using your Gmail address as the from address?

Hello Dexter
I will try both of your suggestions

Al

Could not get it to work with either changes, error message received (Your test email could not be sent: ( [Errno 8] hostname nor servname provided, or not known)

Thoughts

Al

Sounds like you have a DNS error. Can you resolve smtp.gmail.com ?

Yeah, it sounds like a DNS problem, which is also mentioned here from a quick google search http://www.sw33tcode.com/?p=7

Tried different combinations and read the article at http://whatismyipaddress.com/mail-server.

Here are my specifications that I have used:

Your test email could not be sent: [Errno 8] hostname nor servname provided, or not known

Console messages: (Ticked)
Root E-mail: (My [email protected])
From email: (Another gmail [email protected])
Outgoing mail server: (smtp.gmail.com)
Port to connect to: (465)
TLS/SSL: (SSL)
Use SMTP Authentication: (Ticked)
Username: (My email [email protected])
Password: (Password for my Gmail account above)
Password confirmation: (Confirmed Password)

There is some issues stated in the article should I use a none google account?

Could Try a different provider and see if that works.
Try @Dexter_Kane suggestion first - See Below

Try it with only the one Gmail account for all the addresses. Also you need to check that freenas can actually resolve smtp.gmail.com, if you can open a terminal on the freenas machine or SSH in to it run ping smtp.gmail.com

Also have you seen this? http://gamblisfx.com/how-to-setup-email-alert-on-freenas-9-3/

It would atleast indicate that it works with Gmail. From the sound of the error my bet is that it's a DNS issue.

In the set up wizard it asks if I want to create directory service.
Do I need to do this?
In the documentation they said skip this but I do not know now?

Directory Service:
Domain Name (DNS/Realm-Name):
Domain Account Name:
Domain Account Password:

Here are the fields to fill in.

No you don't need that, that's for a windows active directory or LADP.

The reason that I mentioned this is because you feel the issue is a DNS issue

Yeah, the issue looks like you're unable to resolve smtp.gmail.com, so either the dns isn't configured or its something else. Can you ping that domain (from the freenas box) and tell me what it says?

[[email protected] ~]# ping smtp.gmail.com
ping: cannot resolve smtp.gmail.com: Host name lookup failure
[[email protected] ~]#

I found this but I do not know how to appended google’s dns
server to my /etc/resolv.conf

I did have an issue where it couldn’t find the server smtp.gmail.com
which appeared to be a dns issue. To fix this I appended google’s dns
server to my /etc/resolv.conf (which unfortunately this
files gets overridden after every reboot, but it didn’t matter since
this command kicked it in the butt to get it working).
If you go into System -> Advanced menu, there is option to set
commands to be executed after every reboot. I just added new postinit
command:
echo "nameserver 8.8.8.8" >> /etc/resolv.conf

Run the command at the end of your post echo "nameserver 8.8.8.8" >> /etc/resolv.conf but you should do what it says and add it to the commands to be executed after every reboot.

[[email protected] ~]# "nameserver 8.8.8.8" >> /etc/resolv.conf
bash: nameserver 8.8.8.8: command not found
[[email protected] ~]#

You forgot the echo. The command should be: echo "nameserver 8.8.8.8" >> /etc/resolv.conf