FreeNAS 11.2 no plex please help

So i am doing a test server before i deploy FreeNAS to my HP ProLiant DL360 8bay server. Currently i have Win 10 on it and it kinda sucks.

My 2 main focus’s for that server currently are speed to access storage and Plex. I HAVE A 16TB NAS IN RAID 5 SO REDUNDANCY ON THIS SERVER IS NOT NEEDED IT IS FOR SPEED OF ACCESS FOR MY MEDIA AND PROGRAMS.

This seems to be the only “sorage/vm/plex” OS i can actually load onto either of my OLD server “Dell Poweredge 1950” or ASUS tower with “SABERTOOTH 990FX with and AMD FX-8350”.
I can get to the GUI set up the data pool and everything set up groups and people. But when i try to get PLEX on either of them it says that its not available. It makes the Jail so i tried loading it from the shell of the Jail (pkg install plexmediaserver_plexpass).
i get an error saying that it is not available basically.

For the testing purpose i have everything set to DHCP. I want to make sure i have everything working before i change things over to Static.

I am stuck with Comcast internet but i am running through a ARRIS SURFboard SB6190 -->Ubiquiti EdgeRouter 4–>BUFFALO 12-Port 10 Gigabit Switch–> to either server/computer. Everything --> is CAT6

First off, just to clarify, you were trying to install plex with the available plugins and it failed? If so, you should file a bug report to FreeNas.

If you indeed wanted to install plex “by-hand” in a jail, make sure you update the pkg db by running pkg upgrade. Then, you want to install plexmediaserver instead of the plexpass. You can still install plexpass if you need it, but you want to run pkg install plexmediaserver first. If you run into issues, try ASSUME_ALWAYS_YES=YES pkg install plexmediaserver. Then to enable it, run sysrc plexmediaserver=YES and finally service plexmediaserver start to start it. Then you should be able to go to http://:32400/web to see it.



Thank you so much for all the info. I will be trying this shortly.

I know enough to be a danger to myself about this stuff. lol. But i know to ask here when i run into issues. This forum deferentially has alot of smart people on here .

FreeNAS 11.2 is still in beta so all bets are off I am afraid.

FreeNAS 11.1 is the current stable release.

1 Like

for some reason i can not get 11.1 to boot up properly.

Well RC1 is out in two days.

Might help. Their has been a jump in the underlying BSD OS from 11.1. to 11.2 (FreeNAS versions track FreeBSD versions) with a new kernel.

Here it says

Plugins have switched to FreeBSD 11.2-RELEASE and all Plugins have been rebuilt for this version.

So it is not surprising they might not all be 100% at this point.

Not too much to add at this stage, other than my experience with Plex on FreeNAS 11.2 Beta3.
The FreeNAS 11.2 betas have been pretty good for me so far, no real issues.

I have been using iocage for jails since 11.1 though. This means I have had to manually update them with “iocage upgrade jailname -r 11.2-RELEASE”, which has been working fine.

I have also gone down the track of making separate datasets for plex configuration files and all the media types. I also have a specific user with access permissions for all of the media libraries, and I run plex as this user. These are all mapped in the jail fstab file.

I had some time last night to get 11.2 working. For some reason it would say it installed Plex but when i went to set up the jail it was not there.

I ended up trying 11.1 again and everything worked perfectly. I think i’m going to stick with 11.1 for now it will let me do everything i need and it seems to be a bit more complete.

The only reason I want 11.2 is because it supports Ubuntu 18.04 VMs.

The current stable releases kernel can’t support it.


Waiting for the same reason.

I upgraded one of my 16.04 VMs to 18.04 unaware of this issue which only works when I use the older Kernel (4.4.0-134-generic) - which isn’t ideal but should do for now.

Might be a bit late now, but did you try and log into FreeNAS using SSH and manually see what was going on? Use the iocage command to see if the jail was made, and if it was set up right etc.

There comes a point where you won’t be able to update software anymore, since the package repository will be ahead of your current distribution.

But no matter, 11.2 shouldn’t be too far off!

Edit corrected my language.

My main tower is a crazy work station that i do video editing and transcodeing on so i run my VM’s from there and really the only vm i’ll probably toss on the FreeNAS box will be a win 7 VM because i have a HAUPPAUGE WinTV-quadHD and can’t find if FreeNAS supports it.

I figure i’ll get 2 to 4 years out of the current plugin’s just from what I’ve read online about how often people update their FreeNAS boxes to the latest version.

Well I just installed 11.2 RC1 with no issues on my little home FreeNAS system.

Can you post the output of pciconf -lv with the hauppage card attached? I’m not sure what use it would be in FreeNAS anyway, but I can at least help you figure out if a driver exists :slight_smile:

I didn’t know about that. I will try that when i have time this week. I know there are drivers for it in Linux but i haven’t found a way to port the Linux drivers to FreeBSD.