For all the people who are intimidated by i3wm. Fear not!

These 3 videos were great even for someone who has been using i3wm for over a year. This guy is straigh, to the point, clear and explains things in the best way possible. So if you were intimidated by the sheer amount of optimization and customization of this particular wm then watch these videos and I hope it will change your mind about it.

Getting accustomed to the wm

Basic customizations

Pimping out i3wm

Note: These videos are not mine. I just happened to stumble upon them recently and thought some of you would find it useful.


havent watched the videos yet but i LOVE i3. lightweight simple and very minimalist design.

1 Like

I tried some others like awesomewm, bspwm, and dwm. But the only one of them that I considered using was dwm and i put it onto my college laptop because it doesn't have the best performance and this wm is the lightest of them all. Glad to see someone on this forum using i3 :)

yeah works great on old machines that you want a gui for.

I use OpenBox in tiling mode on my main PC, but I'll install i3 in my next system.

1 Like

I love i3, but it was too much of a pain to get working the way I want on my laptop. I often walk away from my laptop, and I usually just close the lid. In Cinnamon it suspends/locks the machine. I haven't been able to find a reliable way for this to happen in i3, just a keyboard shortcut, which is kind of a bummer.

In the third video he gives a link for a cool pixelated lockscreen and some people managed to make it lock after a certain period of inactivity. Here
This might not have the way to make it run after a period of inactivity but I assure you that if you google something related and/or take in the advice below you might be able to tweak it to your liking.

you might be able to create a script that waits for the acpi lid close and runs the lock program.

I tried i3 for a while but found AWESOME to be much more usable and easier to become fluent.

It's possible, and there are threads around the internet of people who've done it. I spent about 30 minutes working on it and trying to get it to suspend properly. In the end though, I can use Cinnamon and it works for me out of the box :/

I still have it installed, and sometimes I'll drop in and work on it, I just don't feel like it's important enough to spend the day tuning everything. So I guess I run i3 as a hobby :D

1 Like

that's how I felt about i3... Awesome works much better out-of-the-box and I can get up and productive pretty quickly.

You can try this. Open up /etc/systemd/logind.conf and uncomment or insert, if not present, HandleLidSwitch=suspend save, reboot and give it a try.

OK, that was embarrassingly simple. HandleLideSwitch was set to ignore.

Now it actually suspends when I close the lid, which is great. That's going to save a lot of battery :D
It doesn't lock, so I'm reading the system.d, xautolock, manual pages. I don't know anything about acpi, so I don't even know where to start there.

You are on a good path :D

There are various ways to do it, I'm sure there is a way to do it within i3 and without using systemd. But I don't use i3. Anyway, i3 provides i3lock, it's a lock screen that you can customize.

Using systemd

I'll describe the systemd approach by writing a custom unit:

Description=Lock the screen on resume from suspend

Replace yourUserNameHere with your username.
Save it as lockScreen.service inside /etc/systemd/system/
Enable it to be loaded at boot and start it:

sudo systemctl enable lockScreen
sudo systemctl start lockScreen

Using acpid

If you have acpid installed you can use the script located in /etc/acpi/ to susped when you close the lid and lock it. Put this inside that file and save it:

    case "$3" in
            logger 'LID closed'
            DISPLAY=:0.0 su $USER -c /usr/bin/i3lock
            logger 'LID opened'
            logger "ACPI action undefined: $3"

With this you don't need HandleLidSwitch=suspend inside /etc/systemd/logind.conf.

I've tried both of these approches before, systemctl returns 'command not found' and I don't have a in /etc/acpi.

I've tried to make one
sudo touch /etc/acpi/
sudo chmod +x /etc/acpi/

I referenced a I found on Github and filled it out, but it doesn't work.

I haven't had issues like this with any other wm. I love using i3 on my laptop, but it just doesn't love me back!

What distro you have?

Linux Mint 17.3, upgraded from 17.2

Apparently Mint provides a version with systemd and one without it. So I guess you have the one without systemd.

I used the second video as a get started on the system Im currently using and it was wonderful!

I will test the third video after I study a bit more.

she says shell study
look at this joker.