Flickering with AMDGPU driver

I received my RX 550 today and Fedora started fine and used the amdgpu driver, but I have two issues so far. The first one is minor: Scrolling doesn’t seem as smooth and there’s a bit of tearing. My main monitor is a Dell UH2515H which is connected over DP. When I disconnect it or switch the inputs, the system thinks it was removed (Windows makes the hardware disconnect sound) and distributes the windows to the other screens. When I reconnect it, everything works fine. But when I do it a second time, all my screens are flickering until I reboot my system. Did anyone ever experience this issue?

I’m not sure about the flickering, but the tearing is relatively easy to fix.

First, install xorg-x11-drv-amdgpu using dnf.

Next, create a file 20-amdgpu.conf in /etc/xorg/xorg.conf.d/ with the following contents:

Section "Device"
   Identifier "AMD RX550"
   Driver "amdgpu"
   Option "TearFree" "true"

Now, just log out and back in or reboot and the tearing should be gone.

That works if he’s using Xorg, but fedora comes defaulted to wayland instead.

I’m not sure if I’m running the wayland session. Is there something similar I could do for wayland?

No not really.

When you log in, there is a little gear box that you can use to select which DE you want to boot in to.

It is shown after you have selected a user. Hit enter or click on your name. A gear-wheel will appear where you can choose the session to run. -in-fedora-21-gnome-desktop-login

Would it be better if I used a Xorg session for now?

I would try the fix I posted with the Xorg session. If it works, then there’s no issue with continuing to use Xorg over Wayland.

I tried the Xorg session now and the scrolling seems better. Also the issue with the flickering monitors is gone. If I wanted to help to get this fixed, where would I need to go?

I’m not certain, but from what I understand of wayland, most of the heavy lifting is done by your compositor, which is generally a part of your desktop environment. Since you’re using gnome, I’d start on their mailing lists or bug tracker.

I have an RX550 on a Fedora Linux box and had the same issue. I found this fix, over on ArchWiki, for a similar issue, that fixed it.

**Screen artifacts and frequency problem**

If you have screen artifacts when setting your screen frequency up to 120+Hz your "Memory Clock" and "GPU Clock" are certainly too low to handle the screen request.

A workaround [2] is saving high or low in /sys/class/drm/card0/device/power_dpm_force_performance_level.

There is a GUI solution where you can manage the "power_dpm" with radeon-profile-gitAUR and radeon-profile-daemon-gitAUR.

So what’s your refresh rate? Or does it also apply to 60 Hz displays?

I was actually having the issue with running a single monitor at 1440p60, I was only able to run it at 1080p and 50hz without flickering. By setting the power state of the RX 550 to stay at higher levels, I am now able to run 1440p at 60hz, on not just one monitor but three.