Fix for installing steam on Ubuntu 14.04 x64 error missing

I have been wrestling with this issue for hours today and I finally found a solution that worked. It's because of the Tek that I switched to Linux and I wanted to share the solution that I found with the community.

I take no credit for this - but if this forum is your first stop for support, hopefully this will help you get Steam installed and working on Ubuntu. Steam was the first thing I tried to install and I immediately had issues, so I figured rather than get discourage, I'd plug on until I found a solution.

You have to at least tell us the system specs. AMD? NVidia? Which GPU? What CPU?

I had an issue like this one:

At the very bottom.

You're right. I haven't posted on a forum in years, I just wasn't thinking about it.

AMD Radeon HD 6xxx video card
AMD A10-5800K

Run steam in the terminal

LIBGL_DEBUG=verbose steam

and see what errors you get. Also, run this

sudo apt-get install mesa-utils
glxinfo | grep OpenGL

Ohhh the problems with libgl.... OK first you HAVE to make sure when installing proprietary driver that you also install the lib32 libraries as well. If that does not work search Google for the answer. I cannot completely remember how I fixed the problem but I know lib32 libraries had to be installed and a restart was needed