First bit of Linux trouble.. Any advice?

So… I had my first Linux goof. Ever since I created my ‘switching to Linux’ thread, I’ve been using Linux and loving it. A few speed bumps, but nothing I nor google couldn’t handle. Until today.

I started in Kubuntu, and recently switched to Manjaro wanting to get into Arch.

Everything worked fine until this morning, and I am not sure what happened.

Event 1:

I boot up my PC from sleeping, everything is fine for about 10-ish minutes. Then, I get thrown into this terminal. Not sure what the name of it is, but I have been in it before, and used it. No biggie. However, for some reason, my keyboard input is locked. It won’t accept anything. No shortcuts, no input… Wait 15 minutes, still nothing…

Event 2:

With keyboard input locked, I had to hard reset. Upon rebooting I get this:

(Something about a Display driver failing to load)

and boot is stuck on TLP loading.

Event 3:

Errr. This was outta my realm of knowledge, so I used the best tool a junior developer has at his disposal. I googled it.

Brought me to a forum which said to use this wonderful guide:

Event 4:

Everything on the guide worked fine. Altho I did have to do the efivarfs step-thing.

There were no errors (Aside for efi vars). No indication of anything being out of whack.

Event 5:

I exit live cd, and boot.

Expecting everything to run smoothly

And on boot I now get:

(Paraphrasing as I forget exactly)
error: Symbol lookup error: GRUB_EFI_NMAP or something.

Nothing will load. This error is displayed in white text, and asks me to hit a key to continue. Which brings me back to the grub selection screen.

Event 5:

Nothing on google about this nmap symbol lookup error. A similar error says to do the guide I followed once again.

I figured I must of borked the guide.

Event 6:

With no other alternatives, I follow the guide again. Only this time:

It now says /boot/efi does not seem like an efi boot or something.

So that is about it. I’ve learned quite a bit about Linux over the past months, but this realm is way outside of my expertise. Not sure what else to do.

What happened? Why? And what did I do wrong?

1 Like

@AnotherDev perhaps you can offer some additional assistance. The steps for manjaro are very similar to the ones in your debian 9 stretch guide.

@ASimpleRadio, can you get us the exact error message in full? There could be a couple of different things happening at once that may or may not be causal to your system locking up. BTW, were you in a GUI when you returned from sleep and what gui was it?

Unless you did something to precipitate it, that looks like a hardware error to me, either logical or physical disk corruption.

I would run a memtest, check SMART on your disk, etc, the usual hardware stuff.

No, it wasn’t a gui. It was the term you get into when hitting alt + ctrl + f2 (or something). It was locked.

The error is:

error: symbol `grub_efi_find_nmap_size’ not found.

I don’t think its hardware, as live CD works, and I can boot into another OS when adding its drive.

Hardware issue corrupted data on your disk, I mean. Also of course do a fsck.

I ran a fsck initially, nothing was found.

Its seems as tho, from whatever I did wrong, it corrupted something during troubleshooting. FSCK says it contains a bad magic number.

That’s unfortunate. Best course of action is probably to reinstall.

On an unrelated note /sarcasm/ does anybody know of any good ways to recover a /home/ that was arrogantly not installed on a separate partition?

Curious: Do you have any of your disks in a raid configuration?

Ahh corrupt superblock. There are ways to try to fix that, it’s backed up to a couple other blocks on the disk. But that really shouldn’t ever happen, like I said, it indicates either logical or physical disk corruption.

I would try to mount the disk from your liveCD, and then copy your data off to a USB flash drive.


No, I dont run my disks in Raid. I probably should, but none of the data I have is imperative.

Thanks for the help Ruffalo. Do you have any idea what could have caused this in the beginning? As I said, the first thing I ran was a FSCk. So whatever initially caused the problem is still unknown…

Noticed these after my last comment. With your error statement only one other person had a similar structure to this error message and it was indicating an issue with the initramfs so I think you guys are on the right track in this troubleshooting.

Like I said, my best guess is something caused either physical or logical disk corruption. Physical means your disk is bad, logical means something else caused bad data to be written; faulty RAM, insufficient cooling/voltage for the CPU, a power spike, sunspots, mercury occluding venus, could be any number of things. Hardware stuff.

Probably not the best way to learn, RAID adds complexity that can cause even more problems from simple mistakes. Having root and /home on different drives alone could cause some headaches. Really depends on where you are at on learning and what you want to achieve when it comes to RAID.