Firefox GTK (?) Problems

Hi :)

I've been having trouble lately with Firefox (And Zotero) and I figured it'd be related to the AMD (catalyst-total) drivers from AUR.

Now, settings that should have checkboxes or radio buttons, simply don't. Which makes it somewhat annoying to use tbh ^^'

Now I am toying around with KDE Plasma 5.2 at the moment, so I am not even sure why the fucking hell Firefox is still being broken.

Any one knows a solution to this problem? Google really didn't do any good for me ><

And I have pacman -Rsn firefox and deleted ~/.mozilla for a fresh install.

Didnt help either.

Here have a screenshot to share my pain:

Same in:
Pulseaudio Controls and so on

My guess is something with GTK and the ATI Drivers is messed up, any ideas?

Running Arch
Catalyst Total Drivers

Thx guys :)

If all of those programs are still broken on plasma 5.2, then something is definitely wrong.

I am assuming you have tried using all default themes, fonts, and there is no weird scaling settings enabled.

Did these problems occur directly after you installed your video card drivers?

I have purged gnome for now, which solved the issue ^^

Now I am enjoying the following fun stuff :D

Plasmadesktop: Segmentation fault (11) -.-'

Ah well, isn't the point of it learning how to fix stuff? ;P