Return to Level1Techs.com

Fighting SMB on Freenas 11.3

Terve!
A couple of day ago I read that the SMB v2 Version problem was fixed with Freenas 11.3, therefore I updated my Freenas 11.2u5 to u7 and then 11.3-rc1.
After setting up user, permissions and min version SMB 2, I get an error that I don’t have permission - that is easly circumvented by connecting the network-storage to my PC and ticking “use different account to sign in”. It automatically suggests the correct username and asks for a password.
However now I get the error that “A device connected to the system is not working”. I’m not sure how I can resolve that problem.
P.S. Every error has been translated from German, so it might not match the English error message 100%.
I can give you the original messages and the Hardware specs if needed.
Thank you in advance.
Sayonara!
Shadow

I have a hard time actually grasping your hole situation and Problem.

So the two or three things that get me basically every time on a new freenas install are that SMB needs a non root user, Kind oft obvious but i forget that sometimes.
In Addition, the dataset ownership and rights are what the SMB Share uses to figure out if you have access to the share. If those differ, the errormessages aren’t always obvious.

And the third thing, on Linux at least with Manjaro, someone decided that it would be a good idea to put a “Max client protocol” setting into the official SMB.conf.

I don’t think that to be a good idea at fucking all.
The config had to be installed manually from the manjaro community repos though, so I was to blame.
But I just didn’t expect such a fucked up BS setting to even exist.

1 Like

Hello
Thank you for taking the time and explaining this.
I took screenshots of all the things that I (re)configured.
I did it from scratch so I didn’t miss anything.
In short: I have created a dedicated, non root user for smb
I left the permissions standard as Freenas suggests them
I checked the smb4.conf file for a max setting - all I found was a min of SMB2 (which is required for Windows 10 iirc).
Here are pictures of the setup: (again sorry for the German, I don’t know how to quickly change that.)

user settings:

dataset settings:
Imgur

Permissions (2 pics):
Imgur

Imgur

login window in windows:
Imgur

login info used (with password):
Imgur

Error message:
Imgur

for the future, you can paste snips directly into the site. its really hard to read through some of the compression on these.

It looks like you have the dataset set to werk1 for owner and group correctly. Can you show the permissions set on the share settings?

2 Likes

Hello
I am not sure what you mean with “permission set on the share settings”.
For me these are already shown in pictures 3 and 4.
If these are not the correct pictures, please let me know where I need to navigate to find what you need.
P.S. I have not found a permissions tab in Windows Explorer.
Thank you for taking the time to look through these blurry images.