Fiber, Ethernet & Connectivity problems


So I finally got off of ADSL and got fibre getting to the house! 
Everything is working fine except one major thing. 

The ethernet used to send signal to the TV was installed by the 
network guy and work just fine. Except my ethernet connection
does not seen to work. The lights on the boxes seem to suggest that 
they are working, I installed just like I did before and that worked 
and the computer can pick up that there is ethernet connection. 

The windows network problems diagnose wizard tells me that
my ethernet connection has no valid IP address. How do I change
this? Is there a way to do this? Sadly I can not pull a cat cable thru 
the house.

Hardware used:
Router: Fritzbox WLAN 7390 (provided by the ISP) 

Switch: Sitecom N300 (still has the same config) 

Ethernet: TP Link PA511KIT AV500 (plug in and play) 

As you might be able to read from the image below, is does identify what type of connection is it.
I follow the steps of the wizard, did not help. Basically turn everything off and on again. 
And the LAN status tell's me I have no IP address being assigned to this connection. 


Any thanks to the people that take the time to read this and if able to help me out!

There is most likely an IP conflict. What you have listed as a "switch" is actually a router. You most likely have an IP conflict or the IPs are not within the same subnet. Check your settings on both the Fritzbox and Sitecom


It's an IP Conflict, this tends to happen a lot when switching networks. Check all your IP's and make sure there within the same subnet.

Basically what @Zanginator said... ^^

thank you for both of you for taking the time. I have searched for tutorials for how to check the subnets and IP's to no avail. Could you tell me how? Or point me in the direction to where I can a find a tutorialto check the subnet and stuff? That would be greatly appreciated!

OK those fritz boxes are literally some of the best you can get, ok, now on your pc go back to the "network and sharing center" then click on "change adapter settings" or "manage networks" then on the Local area connection right click on it then click on " properties" from there double click on "internet protocol version 4" and then in that first window set the IP address and DNS to Automatic configuration then hit ok and ok again.

from there click start type in "CMD" then hit enter
then type "ipconfig -release" then hit ener
then typ "ipconfig -renew" and then hit enter, then close  everything and try the network/internet again

or change adapter settings may be adapterinstellinggen wijzigen in your language? as the above screen shot suggests?

Thank you for helping me! But your comment: "those fritz boxes are literally some of the best you can get" astounded me. I have burnt through 4 of them in 4 years time. 

Really? Iv Only had one, maybe you have dirty power where you are? maybe invest in a surge protector?? But yeah No problems Hope it worked for you

after a few days of playing around and using IPCONFIG this is how far I got... Not very far... Pretty much at point zero. I also was not aware that I had a DHCP server .... Any anyone had experience with this? How do I solve this problem?

looks like the fritz box isnt setup correctly then, I would call the fritz support line or your isp's support line