Fedora Notification says my hard drive is failing (solved - looks like it was my thumb drive)

Yesterday before I went to bed this notification popped up saying my hard drive is failing. I haven't noticed any issues with it, though, so I don't know if this is really my SSD failing or Fedora being stupid.

I ran

 sudo smartctl -a /dev/sda

and got this:

smartctl 6.5 2016-05-07 r4318 [x86_64-linux-4.8.12-300.fc25.x86_64] (local build)
Copyright (C) 2002-16, Bruce Allen, Christian Franke, www.smartmontools.org

Model Family: Crucial/Micron MX100/MX200/M5x0/M600 Client SSDs
Device Model: Crucial_CT256M550SSD1
Serial Number: 14330E00D417
LU WWN Device Id: 5 00a075 10e00d417
Firmware Version: MU02
User Capacity: 256,060,514,304 bytes [256 GB]
Sector Sizes: 512 bytes logical, 4096 bytes physical
Rotation Rate: Solid State Device
Form Factor: 2.5 inches
Device is: In smartctl database [for details use: -P show]
ATA Version is: ACS-2, ATA8-ACS T13/1699-D revision 6
SATA Version is: SATA 3.1, 6.0 Gb/s (current: 6.0 Gb/s)
Local Time is: Tue Dec 13 12:03:47 2016 CET
SMART support is: Available - device has SMART capability.
SMART support is: Enabled

SMART overall-health self-assessment test result: PASSED

General SMART Values:
Offline data collection status: (0x00) Offline data collection activity
was never started.
Auto Offline Data Collection: Disabled.
Self-test execution status: ( 0) The previous self-test routine completed
without error or no self-test has ever
been run.
Total time to complete Offline
data collection: ( 1190) seconds.
Offline data collection
capabilities: (0x7b) SMART execute Offline immediate.
Auto Offline data collection on/off support.
Suspend Offline collection upon new
Offline surface scan supported.
Self-test supported.
Conveyance Self-test supported.
Selective Self-test supported.
SMART capabilities: (0x0003) Saves SMART data before entering
power-saving mode.
Supports SMART auto save timer.
Error logging capability: (0x01) Error logging supported.
General Purpose Logging supported.
Short self-test routine
recommended polling time: ( 2) minutes.
Extended self-test routine
recommended polling time: ( 3) minutes.
Conveyance self-test routine
recommended polling time: ( 3) minutes.
SCT capabilities: (0x0035) SCT Status supported.
SCT Feature Control supported.
SCT Data Table supported.

SMART Attributes Data Structure revision number: 16
Vendor Specific SMART Attributes with Thresholds:
1 Raw_Read_Error_Rate 0x002f 100 100 000 Pre-fail Always - 0
5 Reallocate_NAND_Blk_Cnt 0x0033 100 100 000 Pre-fail Always - 0
9 Power_On_Hours 0x0032 100 100 000 Old_age Always - 5579
12 Power_Cycle_Count 0x0032 100 100 000 Old_age Always - 534
171 Program_Fail_Count 0x0032 100 100 000 Old_age Always - 0
172 Erase_Fail_Count 0x0032 100 100 000 Old_age Always - 0
173 Ave_Block-Erase_Count 0x0032 095 095 000 Old_age Always - 158
174 Unexpect_Power_Loss_Ct 0x0032 100 100 000 Old_age Always - 25
180 Unused_Reserve_NAND_Blk 0x0033 000 000 000 Pre-fail Always - 2159
183 SATA_Interfac_Downshift 0x0032 100 100 000 Old_age Always - 0
184 Error_Correction_Count 0x0032 100 100 000 Old_age Always - 0
187 Reported_Uncorrect 0x0032 100 100 000 Old_age Always - 0
194 Temperature_Celsius 0x0022 064 053 000 Old_age Always - 36 (Min/Max 21/47)
196 Reallocated_Event_Count 0x0032 100 100 000 Old_age Always - 0
197 Current_Pending_Sector 0x0032 100 100 000 Old_age Always - 0
198 Offline_Uncorrectable 0x0030 100 100 000 Old_age Offline - 0
199 UDMA_CRC_Error_Count 0x0032 100 100 000 Old_age Always - 0
202 Percent_Lifetime_Used 0x0031 095 095 000 Pre-fail Offline - 5
206 Write_Error_Rate 0x000e 100 100 000 Old_age Always - 0
210 Success_RAIN_Recov_Cnt 0x0032 100 100 000 Old_age Always - 0
246 Total_Host_Sector_Write 0x0032 100 100 000 Old_age Always - 12029181689
247 Host_Program_Page_Count 0x0032 100 100 000 Old_age Always - 409018129
248 Bckgnd_Program_Page_Cnt 0x0032 100 100 000 Old_age Always - 1979532157

SMART Error Log Version: 1
No Errors Logged

SMART Self-test log structure revision number 1
No self-tests have been logged. [To run self-tests, use: smartctl -t]

SMART Selective self-test log data structure revision number 1
1 0 0 Not_testing
2 0 0 Not_testing
3 0 0 Not_testing
4 0 0 Not_testing
5 0 0 Not_testing
Selective self-test flags (0x0):
After scanning selected spans, do NOT read-scan remainder of disk.
If Selective self-test is pending on power-up, resume after 0 minute delay.

Search for bad blocks showed 0.

Checking blocks 0 to 250059095
Checking for bad blocks (read-only test): done
Pass completed, 0 bad blocks found. (0/0/0 errors)

Anyone got any ideas?

Yes. Run smartctl for /dev/sdb, as it says in the error message, not for /dev/sda.

1 Like

Smartctl open device: /dev/sdb failed: No such device

edit: wait...would /dev/sdb be a second component connected via SATA? cause that would be my optical drive.

Your optical drive would probably be something like /dev/sr0, not sdX. I'd guess it's either another drive or external/USB drive, but it's your box, you know better what's installed there.

Currently I have only one SSD installed (HDD is failing so I took it out a while ago, that didn't cause the error message). I had thumb drive and my smartphone plugged in yesterday.

Just tried it, /dev/sdb is my thumb drive. Smartctl didn't show any errors, though. I unmounted it correctly yesterday.

Is is an old Thump Drive, maybe it is failing?

It's a Sandisk Extreme that I bought in March 2015. Wouldn't call that old.

Check for bad blocks shows a bunch of errors already. Currently at (96/0/0 errors).

That isn't old, I agree. but seems like the stick is dying. Is it by default plugged in your computer? Or you use it from time to time?

I just use it for transfer media files from my desktop to my laptop. Doesn't happen that often.

But is it plugged in your computer most of the time?

No, only when it's in use. As soon as I'm done transfering files I remove it.

if you run

sudo fdisk -l

it will tell you what drive is what


Strange, maybe check if you have warranty left on the stick.

If you had plugged it in all the time I would say some program or process is periodically checking the drive and wearing it.

I'll check with Amazon but I doubt it (eventhough Sandisk gives 30 years of warranty on teh Extreme thumb drives).

Good luck! Happy Holidays!

1 Like

Thanks, happy holidays to you too!

Got the notification today again after I used the thumb drive on my laptop. I unmounted the thumb drive, unplugged it and some time after that I got the notification - when the thumb drive wasn't even plugged in anymore.

I confirmed with @Dje4321 's advice that /dev/sdb is indeed my the thumb drive.

Ran HDTune on my desktop and it showed no damaged blocks.

yup this just happened to my kingston drive today... it was acting weird. however it never warned when before dying

did your drive actually die or did the OS just say that it is failing?

That is the problem with SSD and USB Flash drives compared to HDD. HDD gives you a warning when they die. An SSD of USB Flash drive just die... :(

I get that...but the thing is: the thumb drive still works even though I get those notifications.