Fedora F27-->F28 mouse lag / high cpu ussage


Just upgraded from working Fedora f27 to f28. Using gnome. And now my usb mouse(logitech g400) is acting rely strange. Realy choppy mouse movment and high cpu usage, then all of a sudden working as it use to but when i move any window or click menu the shoppy/laggy mouse movement is back. installed on real machine no vm.

Hope you guys have any idea or suggestions on what to try to fix this… Almost unusable now.
Havent tried to boot old kernel.


Have you tried changing the battery on your mouse (if wireless). I know that funny but worth the try…

Switch from wayland to X11, does the issue go away?

mouse workes perfect in windows… yes i dubble dip.

will try x11 when i am at home…

This is a problem in Gnome that I was experiencing in 17.10.1 on Wayland and X11 both. When I used anything else it stopped.

Ahh, regression issues.

1 Like


Use any other DE and you’ll be fine.

changed to x11, now it works like it should do… Super great, thak you!


Yeah wayland doesnt really seem to go that well yet,
allthough i thought that with Fedora 27 it worked okayish for the most part?
Still on Ubuntu 18.04 releases they also switched back to Xorg,
because wayland didnt work well on the 17.10 releases.

Fedora 26 or 27 was the first distro that shipped with wayland by default.