Return to Level1Techs.com

Fedora 31 AMD Davinci Resolve

I’m pretty sure I’m almost they’re on getting Davinci Resolve 16 running in fedora 31, but I need help with path linking.

I installed these rpms

amdgpu-core-19.30-855429.el8.noarch.rpm
amdgpu-pro-core-19.30-855429.el8.noarch.rpm
clinfo-amdgpu-pro-19.30-855429.el8.x86_64.rpm
libdrm-amdgpu-2.4.98-855429.el8.x86_64.rpm
libdrm-amdgpu-common-1.0.0-855429.el8.noarch.rpm
libopencl-amdgpu-pro-19.30-855429.el8.x86_64.rpm
opencl-amdgpu-pro-comgr-19.30-855429.el8.x86_64.rpm
opencl-amdgpu-pro-icd-19.30-855429.el8.x86_64.rpm

Now three OpenCL Platforms are installed

clinfo reveals three platforms
1 AMD Accelerated Parallel Processing this is what I just installed
2 Portable Computing Language
3 Clover

path to amdpro is /opt/amdgpu and /opt/amdgpu-pro
path to resolve is /opt/resolve/bin/resolve

currently resolve crashes my guess is it’s not using the amdgpu-pro opencl I just installed.

How would you go about making sure Resolve loads the right OpenCL Platform?

Thanks

I had Resolve working on F29 and F30, by extracting the above mentioned files from AMDGPU-PRO driver. F31 simply fails to start 15.3 or 16.1 though.

Fedora 31 worked with a particular amdgpu-pro driver with davinci resolve 15.3.1, but from what I can see with clinfo. I think Resolve is using Portable Computing Language or Clover, but I need to find out how to get resolve to detect AMD Accelerated Parallel Processing.

I don’t have the knowledge on how to properly link paths, another thought was removing clover and portable computing language which I also don’t know how to do.

Currently resolve works great using

./amdgpu-pro-install --opencl=pal
./amdgpu-install --opencl=pal

Only the Polaris Cards seem to work with davinci resolve as my r9 390 and 7970 failed to detect opencl.

Technically ./amdgpu-install requires you to disable Use GPU Scopes under

/preferences/memory&gpu to use the color grading scopes

Apparently Manjaro was working with older editions of resolve in the aur repo using older ./amdgpu-pro in the aur repo.

That’s the kind of stuff that annoys me about fast rolling distros as they don’t keep a good record of older packages.
Which isn’t good when newer packages are broken.

Linux Mint seems to be that way to go, I’m really excited for 19.3 which will run on kernel 5.0 which works with ./amdgpu-pro-install

Seems Linux Mint Devs are really aware of where AMD is at and don’t want to push forward where AMD has yet to provide OpenCL support.

ROCm technically works with Davinci Resolve if you have Davinci Resolve installed and upgrade rocm, but a fresh install of the current rocm does not work.

Gaming wise ./amdgpu-install seems to use mesa and runs fine with wine-staging, ./amdgpu-pro-install uses openGL 4.6 and works with wine-staging, I’ve noticed very little difference in performance though every game will depend.

I think a lot of people haven’t noticed that amd proprietary drivers have caught up a lot with open drivers for gaming.

Screen tearing is an issue with ./amdgpu-pro-install

sudo nano /X11/xorg.conf.d/20-amdgpu.conf

might have to mkdir 20-amdgpu.conf

Section “Device”
Identifier “AMD”
Driver “amdgpu”
Option “DRI” “3”
Option “TearFree” “true”
EndSection

They’re are multiple ways to do that and sometimes it doesn’t work, but eventually you edit the right thing and it will fix screen tearing.

Kernel 5.3 works with ./amdgpu-pro-install if it’s already been installed with kernel 4.15 or kernel 5.0

Again this is why I like Linux Mint because it supports 4.15 kernel 5.0 kernel and 5.3 kernel and they all run stable.

Need an ubuntu 18.04 based distro for Resolve/ given I had some luck with Debian and Zorin using rocm at a particular time.

Resolve runs with with kernel 5.3

They’re are some ways to install ./amdgpu-pro-install on a 5.3 kernel, but I find it much safer and stable to install on kernel 4.15 or kernel 5.0 and then upgrade to kernel 5.3 after install ./amdgpu-pro-install.

Again, that’s why Linux Mint works really well.

I’ll be curious to see if I can install davinci resolve video desktop drivers on kernel 5.0 haven’t tried that yet.

I wish there was an easy way to install rocm on Fedora. It’s way too much try&error to figure stuff out just for this one application.

ya works great on linux mint if you use amd’s official linux drivers

You also need:

opencl-orca-amdgpu-pro-icd-19.30-855429.el8.x86_64.rpm

With that LibreOffice at least works with OpenCL. Resolve 16.1.1 still crashes at startup. Resolve 15.3.1 works just fine.