Fedora 25 installation black screen

I tried to install Fedora 25 on my desktop PC. When I start the installation, my screen goes to standby and I can't switch to a console either. If I use the nomodeset option, it boots fine. My GPU is a 980 Ti. This bug report desribes my situation pretty accurately. Does any one of you know a solution to my problem?

Can you get to a TTYL with CTRL+ALT+F2?

Also, what is the default graphics adapter in your BIOS?

I can't unfortunately.

It's my 980 Ti. My i5 has an integrated graphics, but I don't use it.

Try connecting to your iGPU on your mobo.
Most likely you need to go into UEFI and set your primary GPU or VGA to your 980ti.

EDIT It's not likely to be an issue with XORG or Noueavu (Open Source NVIDIA drivers.)

Can you get a TTY using nomodeset?

@BelisarusRexRPM it almost always is due to nouveau? You seen this before to suggest otherwise?

I just checked and my 980 Ti is the default GPU in the UEFI.

Yes, the GUI works fine with nomodeset just a low resolution and I can get a TTY.

I installed a few days ago and booted with Nouveau but had the same issue until I changed my primary GPU off of the intel iGPU. I have since blacklisted and pci-stubed it so I can pass it through to a Win 10 VM. Cannot try to recreate at this time.

Well just saw his update, Looks like it is Nouevau again... Sigh.

1 Like

Have you run updates after the initial install?
Try running that in a ttyl as root.

It will be helpful for troubleshooting if we know the system is up to date.

Did you disable the iGPU? If you did thats one to try @DennisG1 completely disable it.

But ive seen it a common issue, it usually goes away as soon as you install the proprietary drivers.

I usually suggest using an updated community ISO https://dl.fedoraproject.org/pub/alt/live-respins/

but you may as well update first on the distro. then install the proprietary drivers.

Nope, it is active. After install, I swapped it back to primary as the iGPU and blacklisted the 980ti for my Win10 VM.

I'm trying to install Fedora, so I don't have a installation that I can install updates on yet. I could install it using nomodeset and then install updates, if you think that could help.

The iGPU should be disabled, at least it doesn't show up in the Windows Device Manager.

Yes you can install with nomodeset set. or you can disable your nvidia card for the install

1 Like

That or you can switch to the iGPU and install Fedora install the NVIDIA 1st party drivers and after that swap the primary GPU to the 980ti.

The key here as @Eden mentioned earlier is to get the 1st party drivers installed. Also if you get updates after install there may be a fix that was not yet put into the iso image.

1 Like

If you've not installed it yet, id suggest using a updated respin from the link i game above. might help

I'll try to do that. I'll also try the updated respin you suggested

If you have the time I'd also suggest you post on that bug adding what info you have and that your system is also affected.

1 Like

With the updated spin, the issue still persists. I will install it now using nomodeset

I had a similar issue with my Fedora 25 install - mine was resolved by swapping SATA cables from the mobo controller to the intel controller.

I tried installing it with nomodeset but the resolution was just unusable. I looked around in the UEFI a bit and tried to turn off the so called Windows 8 Features (Fast Boot, Secure Boot, UEFI GOP) which solved it. Do you see any problem with leaving those disabled?


Interesting, So I have that disabled normally so I did not think of that.