Fedora 23 - "Oh no, something went wrong, unable to recover"

I installed Fedora and managed to get it running until I'm unable to run settings. So I reboot my computer and this happened.

(picture in the web that is exactly what happened to me)

While searching the web, it seems that users are able to reach the login screen while the error of mine appears before login, right after the Fedora logo is completed.

I have attempted many different steps to get the thing running again as I do not wish to reinstall. These are the list of events/milestones that I have encountered while using Fedora.

1 - Install Fedora 23 Workstation

2 - dnf upgrade (or update, i cant remember. This command was executed when I encountered the error of freezing when logging in)

3 - Installed Google Chrome (with repos), turned off mouse acceleration with xinput libinput method

4 - Installed Nvida driver & steam repos and Steam (

5 - Unable to start up settings menu, thus reboot

6 - Encounters the error

7 - dnf install @kde (does not work, login screen did not appear due to the error)

What are the steps here could have gone wrong for me? Thanks in advance.

I would say that something happened with the dnf upgrade or dnf update command. I suppose you could boot into a live cd and chroot yourself into your fedora install and then run the command again and look for errors.

I think he was able to access the console with ctrl+alt+f3.

I can say with about 95% certainty that this is graphics related. Purge your nvidia drivers.

Then install the nvidia-drivers package from the negativo17 repo.

I put up some quick instructions on using the negativo17 nvidia drivers on the fedora guide im writing https://tekwiki.beylix.co.uk/index.php/Fedora_Install_and_Getting_Started#Those_evil_non-free_packages_and_everything_else

The basics are as follows (Remember to remove the old drivers)

First enable the negativo17 nvidia repo

dnf config-manager --add-repo=http://negativo17.org/repos/fedora-nvidia.repo

Next install the nvidia-driver akmod module and kernel headers so its build with your current kernel.

dnf install nvidia-driver akmod-nvidia kernel-devel

You should be good to go and can reboot for it to take effect.

I need to test this as i did this a while ago, please let me know in the forum or talk page if this doesnt work.

Additionally if you are using steam youll want the 32 bit version for nvidia

dnf install nvidia-driver-libs.i686

I have done the steps and it still give me the same error. Is there anything else I can do?

Try setting nomodeset in the grub kernel line on boot.

Or remove the nvidia-drivers and revert to the open driver and make sure it works without binary blobs, them work for, there.

How do I do that??

To set nomodeset:
1. Edit /etc/default/grub and add nomodeset to the GRUB_CMDLINE_LINUX variable.
2. Save the changes with sudo grub2-mkconfig -o /boot/grub2/grub.cfg

I took my time to reinstall Fedora and check which step went wrong. Apparently, Nvidia driver is giving the problem, I have installed the akmod module for Nvidia and same thing happen. Settings menu unable to start up, and giving the same error when sign out or reboot.

How can I solve this?

Is there a specific code for this?

You just literally do what he said. However change the second command to grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg if your using EFI, which you probably are.

You might want to get rid of all the nvidia drivers and start again dnf remove *nvidia*

The thing is, I cannot access GUI, so the codes like gedit and other txt editor will not work for me. What should I type in the terminal?

I managed to fix the driver problem by dnf remove and then dnf upgrade. However, I suppose game performance won't be fantastic without the driver and I cannot install steam without the driver right?

use Nano and type the code in the file.

So what you type into BASH (The CLI)

nano /etc/default/grub.cfg

it should open up the file from BASH where you can add a code.

Do I just override the commands? Or just add another "" with nomodeset in it?

So I just simply replace the codes in the second line?

You just add nomodeset somewhere in the string of settings (called kernel parameters). Example: GRUB_CMDLINE_LINUX=" ... rhgb quiet nomodeset"

You have to use grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg if you are using EFI which you probably are like Eden said. The command in GRUB_DISTRIBUTOR just returns the the OS name, if you run it with echo in front of it, it will just print "Fedora".

Also, the same thing just happened to me as well on Fedora 23 after updating to kernel 4.4.5-300, nomodeset was already set, had to remove my nvidia drivers.

This sucks, if it was working perfectly well before you upgraded, I suppose it is Fedora's end that is having problem. Has anyone made a bug report about it yet?

I am not finding anything on bugzilla but they will probably fix it in the near future, will try to install the drivers again after the next kernel update.

Where can I find changelogs of this update? Any twitter that I can follow?

You can see all the bugs in the kernel on bugzilla.

You can also search for kernel-core in yumex-dnf if you have it installed, select the package and click on the Package Update Information button (up arrow symbol) and see what bugs have been fixed in the last releases (with links):

       Release : FEDORA-2016-d4741aaf61
          Type : Enhancement
        Issued : 2016-03-17 17:03:46

   Description : The 4.4.5 update contains a number of important fixes across the tree

       Release : FEDORA-2016-e6cfaff4b1
          Type : Security
        Issued : 2016-03-11 10:31:28

      Bugzilla : 1314255 - kernel: Partial SMAP bypass on 64-bit Linux kernels [fedora-all]
               : 1314253 - kernel: Partial SMAP bypass on 64-bit Linux kernels
               : 1313318 - X/Intel display/Regression: flickering display on 4.4.2-301
               : 1310252 - kernel-4.4.2-300.fc23.x86_64 causes screen flickering
               : 1313433 - CVE-2016-2847 kernel: pipe: limit the per-user amount of pages allocated in pipes [fedora-all]
               : 1313428 - CVE-2016-2847 kernel: pipe: limit the per-user amount of pages allocated in pipes

   Description : The 4.4.4 update contains a number of important fixes across the tree. This also includes an important update for XFS utils.

For some reason they didn't add any references to bugzilla in the last release.

Edit: Here is the linux kernel changelog for 4.4.5 https://www.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.4.5 (not the Fedora specific one though).

I am curious how did you install the nvidia drivers? Was it through a repo or a script from Nvidia website?