Faulty RAM Issues, Help!

Hello, I use a 2x8GB Corsair Vengeance 1866mhz cl10 memory, when I first installed windows 7 I got a couple of blue screens, but after that it installed without problems. However, the blue screens did not stop. My rig also ran my memory at 9-9-9-24 1.5V while the referenced timings are 10-11-10-30 2T at 1.5v but when I tried changing to these settings my pc wouldn't come back on, I had to press memok to get stability again at 1333mhz 9-9-9-24. This was kind of annoying but at least the system was running fine so I did not pay too much attention to it.

But as I used this right (it's 2nd week now) it would create several blue screens:

page fault in non paged area

.irql not less or equal 

system thread exception not handled 

system service exception

cache manager (once only)

the faulty programs are generally ntoskrnl and dxgmms1.sys

so I ran Windows Memory Diagnostic Tool, it detected memory hardware problems. So I got really curious and ran memtest 4.2 

it reported whoopping 2300+ errors in just under 30 minutes. BUT, memtest settings was on DDR-1600 CAS 1-3-3-3. Isn't that odd? It's supposed to run at 1333 9-9-9-24 because those are the current settings at uefi. Should I trust memory diagnostic tool + memtest in their error findings? Any possiblity that the reason for errors are because of the wrong reported settings in memtest or mainboard slots or something? 

(PS Memtest tended to report errors only after 10GB-16GB mark, might this mean that one of slots might actually be fine while it's the 2nd stick at fault)


Thank you for all your help


try pulling a stick and trying memtest again, if it doesn't yeald an error, run the other stick. if its the same, try running both sticks in seperate channels.

also- go into your BIOs and enable ECC, that fixed the system thread exception not handled  and system service exception BSODs for me.

either your bios needs updating, your motherboard just aint compatible with that (it happens but rarely) or your ram is fucked...

im going with your ram is fucked, but check over the other two be sure, but if windows and memtest is reporting issues it's most likely the ram, get it RMA'd

surely it has to be error correction code based RAM to do that in the first place? or am i missing something...

Corsair Vengeance ram is allways under clocked from my experience every set of 1600mhz sticks ive had have been set at 1333mhz  and ive had to set them in the bios ...but if your rams fulty just send them back 

I'll try to test each stick seperately for starters to check whether if it's just 1 ram stick that is the cause of the issues. I'll also try them on different motherboard slots to eliminate motherboard as possible culprit. Here are my full specs just to make this clearer:

Asus Sabertooth 990fx R2.0 (No way this motherboard doesn't support that ram, it'd be absurd)

AMD FX 8350 @ 4.6GHz

HIS HD 4870

I checked internet about the various issues I experience which generally focus on drivers as the problem but apart from downloading latest bios (I am not keen on updating it I run the risk of instability with each update. No need to update if it works fine, I doubt the reason is the bios, motherboard is a R2.0 so it's fairly new)

I am for the most part convinced the issue is due to ram, but I did hear rumors of AMD Driver let instabilities or instabilities with Norton Antivirus program (which I have)

please be forthcoming with more suggestions, thanks for your help


RAM aside get rid of norton... for the sake of hummanity.

also try downclocking your cpu a little and then try setting the ram up again, might be a powerdraw issue but not likely.

also try your old ram if you have any to see if if it's the ram slots, once again not likely

Well i'd rather stab my self in the balls than use norton,it has to hands down the worst A/V there is if its just the free vershon that came with the softewhere you got with the  motherboard just get rid of it 

Norton Removal Tool