Failed Kingston HyperX 3k

Hey just wondering if anyone else has had one of these fail??

I have the 120Gb and it today it is no longer detectable. I tried swaping Sata cables and power cables. Also tried different sata ports on the mobo. Then I placed it in an external enclosure and plugged it into the usb of another OS and nothing.

Had it just under 4 months. Bit of a bummer. 

I haven't used the HyperX, but I had a similar issue with my OCz Agility 3. Every once in a while, I'd BSOD, SSD wouldn't be recognized by BIOS, and after a few reboots, it's detected. I finally updated the firmware, and no issues since.I'm not sure if the HyperX series has that issue, but a lot of the earlier SandForce drives were notorious for firmware issues, OCz particularity.

I'd boot up directly into the BIOS and see if it's detected. If it does show up, update the firmware. If not repeat 2 or 3 more times. If it still doesn't show up, it should be under warranty, and if/when you get a replacement unit, I'd immediately check for firmware updates and install those.

I've got a Kingston HyperX 3K but it hasn't failed. Failure rates on those SSDs are quite low. 

SSD Failure Rates:

  • Intel 0,59%
  • Corsair 2,17%
  • Crucial 2,25%
  • Kingston 2,39%
  • OCZ 2,93%


Hey thanks, I  booted into the Bios about 15 times, with all different Sata cables + different sata ports and nothing.

Yeah when I get a replacement I'll check firmware straight up.