Return to

FAHControl on Ubuntu Server 20.04 install issues


I’m pretty new to being a server administrator and Linux. I just picked up a Dell poweredge r430 server and I have installed Ubuntu server 20.04 on it, even managed to get a gui installed and plan on setting up a ftp server, minecraft server, and folding at home. So far I have managed to get the minecraft server program installed and am now working on the FAH stuff. I have managed to get the FAHclient installed and working through the web client but when I try to install the FAHcontroler it says that python, python-gnome2, and another package is missing. I have python 2 and 3 installed but am at a bit of a loss as to what I need to do… My Google research says that those particular packages are not in the repository anymore. I will try to update this with pictures when I get home from work.

Correct. You will have to manually find and install the .deb packages because FAH is designed to be slow moving. A lot of their package are far too old.

CentOS 7 / Ubuntu 16.04 era stuff is really the latest what will work with FAHControl.

To be frank though you don’t need the Control software, the only thing you need is the FAHClient and you can manage it via the CLI.

Sysadmins don’t use GUI’s :wink:

This being my first forray into Linux I guess I should get used to using terminal stuff, was hoping to use the gui to try to get a little more acclimated to how things work before going completely terminal with it

If this is your first foray into Linux and you are trying to run FAH on anything newer than Ubuntu 18.04 (or even 16.04) , you are defintely in for a challenge. FAHControl doesn’t work on 20.04. Your have a choice: run FAHControl on a remote machine to control your server or just go the command line option.

If you do go the CLI route, here are some pointers:

  1. The configuration file (undocumented) is in /etc/fahclient/config.xml. Be sure to edit your name, team number and passkey. Here is an example:
  <!-- HTTP Server -->
  <allow v=' '/>

  <!-- Network -->
  <proxy v=':8080'/>

  <!-- User Information -->
  <passkey v='REPLACEME'/>
  <team v='232084'/>
  <user v='yourname'/>

  <!-- Web Server -->
  <web-allow v=''/>
  <!-- No GPU  -->
  <gpu v='false'/>

  <!-- Folding Slots -->
  <slot id='0' type='CPU'/>
  1. Starting the FAH client is sudo /etc/init.d/FAHClient start
  2. Stopping is sudo /etc/init.d/FAHClient stop
  3. You can watch the log with tail -f /var/lib/fahclient/log.txt. Ctrl-C to quit that.
  4. It should be obvious from top or ps if it is running, but you can always do sudo /etc/init.d/FAHClient status to see if the service is running.
1 Like

Thank you, I was planning on using a different computer to control the client, I’m just used to using the FAH controller to set it up that way.

If you run into trouble setting that up, let us know. We might be able to help a bit.

Good luck!

It took me a little bit to figure out how to edit the file but I manage to do it. Thanks for the help, I can now control it from my main computer.

1 Like