External DAC cutting out periodically [Solved-ish and update added 23-6-21]

I have an ongoing issue and I am completely at a loss as to what is actually happening as I though I had it fixed several times now, in the sort of way that it worked but I have no idea why.

Relevant specs:
MSi MPG Gaming Edge Wifi
Optoma NuForce uDAC3 USB

When I first put together my PC I had the peripherals plugged in like I had before, starting from the USB ports at the top of the back panel and working down.

Immediately anything I did that made sound would cut in and out, the DACs light changing from white (active) to blue (inactive). YouTube’s videos, music, windows noises when you change volume, etc. Anything with sound for any length of time would cut in and out with a very slight click of static as it cut out, and the windows volume noise would end with the same click of static when it ended naturally not cut short.

I switched USB ports and noticed I got some more time between cut outs and finally found that the very bottom USB ports joined to the Ethernet port did not cause this cutting out.


Playing Art of Rally after maybe 20-30 minutes it starts cutting out again, only in this one game, when I stop playing it goes away. The game has constant sound, music and car noises which is relevant as the way to “fix” this is to have music or a YouTube video or something making constant sound and keeping the DAC active? No idea how the game keeping it active is not the same as other stuff keeping it active. Especially when before in the upper ports constant sound did not help it there.

This gets annoying as I am usually talking on discord while playing and will miss seconds of talk when the sound cuts out and occasionally does not come back until I unplug and plug it back in.

This is more annoying than critical but at this stage I just want to know why.

I am not sure if any other games cause this, Art of Rally is the only one I have come across so far.

Edit: I was using this very same DAC with my previous PC absolutely flawlessly, AM3+ FX 6100, Win 8.1, Gigabyte GA-970A-DS3 motherboad.

I’m currently using a FiiO K3 and if no sound is played for a long enough time (few seconds) it switches the output off and it doesen’t come back until a sound is played. So, for my experience, your DAC is acting normally.

If you’re not experiencing cut outs while listening to something you’re fine. Maybe the threshold is too low because when I’m in calls, in general, I don’t experience cut out.

Onto the possible solution: if the device has any specific drivers there should be a way to keep the output constantly on and not having it switch off. For the FiiO K3 you need to modify a property file and the option appears in the drivers control panel.
There should be a way to do the same for your DAC.

P.S. I don’t know if the light on the device cutting out is a choice or not, but it’s weird that it does when the output is not active.

Yeah it does the same, goes inactive if sound is not playing


It does cut out while sound is playing too, just randomly. Regardless of volume. My PC system volume is always at max and I control the volume from the knob on the DAC. Even if my music is playing at very low volume it will keep it active and stop the cutting out so it is not a threshold problem as far as I can tell.

It has no drivers, just the standard windows audio driver. I have no idea about modifying anything that could be interesting if you have more information, but there is no driver control panel per se as it is just using the generic windows driver as it was intended to do.

The light is just another indicator if the output is, well, outputting.

Edit: I was using this very same DAC with my previous PC absolutely flawlessly, AM3+ FX 6100, Win 8.1, Gigabyte GA-970A-DS3 motherboad.

I went through your post one more time and realized that’s what you tried to say. And that moving the USB port fixed it for a bit and then it started acting up again after playing Art of Rally.

Going on the device’s page on the manufacturer website it lists an ASIO driver available, but I don’t know if it’s a generic ASIO driver or it’s intended to be paired with the device.

Well this this doesen’t bring my hopes up. I’ve been having a shit ton of issues with a Logitech Streamcam that works fine on other PCs it seems so it might be related to the Ryzen USB drivers.
What I would try then is to dowload the latest USB drivers from MSI’s page for your board and try if the DAC keeps working. This fixed my webcam for some days but then it “broke” again so maybe it’s a more permanent fix for you.

I will definitely try.

I was thinking too about the ASIO drivers, they usually are generic which is fine, but I am not sure if that remains an open to all use driver or if it is a one program one output type of deal like WASAPI does.

My only experience with ASIO is for my FocusRite Scarlett Solo where it is used for interfacing with Ableton Live better.

In FiiO’s case the ASIO drivers are specific for the device and are used for the exclusive mode in Foobar2000 (bit perfect playback + DSD support) so they might be used for the same reason. I won’t discard them immediatly.

Yeah, those are “just” used for low latency audio.

I hope it helps and fixes it once and for all! I hate having to deal with these kind of issues, annoying.

1 Like

Yeah that the same as the WASAPI output in Foobar2000 better quality but makes the device exclusive to the program.

I won’t discount it either, I will try but not very high hopes as usually ASIO needs a both sides agree component and I don’t know is windows has that for just system sound. Like with the Scarlett Solo you connect Abletons ASIO output to the ASIO4ALL driver/program and it is an exclusive thing too, as far as I remember, it has been a while.

1 Like

Windows doesn’t take the ASIO drivers into account when playing back sounds in “shared mode” but maybe there’s also more to them to make the device work better in Windows.
Like this one.

1 Like

So far no dice. Updated all the drivers from the MSi site, none specifically mentioned USB. Still happening after those updates.

Installed the ASIO control panel for the uDAC3 and it is just for exclusive output for things like Foobar2000 which is their example use case and guide on how to set that up.


That all you get from it.

Just bought Need For Speed: Hot Pursuit Remastered… It make the same thing happen but only in some places, like when I unlock a new car or the reward screen, otherwise it works fine.

A friend floated the idea it is maybe tied to CPU utilisation. Have not checked it yet or come up with a way how just yet.

Edit: Okay, ran for a while with Task Manager open and the CPU barely got to 20%, GPU never got to 100%.

I am using a cable with no ferrite chokes on it, that could be the next thing to find and try. Might also try the front USB Ports, ugly as it is if it works I will be happy.

EDIT 2: So on watching individual cores rather than total utilisation, while waiting on a a start screen for a race I was getting semi regularly spaced clicks in the sound, not full drop outs but interruptions. It seems to correspond with individual cores hitting 100%.

Not really sure what to make of or do with this information, Is there any way to rule this out?

EDIT 3: Is there any way I can force a constant peaking of 100% load on and off across cores, not constant load but intermittent bouncing against 100%. Even better if I can make individual cores do it and see what happens.

EDIT 4: Okay more information. All things exactly the same as the last edit except now I have a YouTube video playing too, the browser was open before but doing nothing, now that a video is playing individual cores are still peaking at 100% but there is no cutting out. The only difference is a video playing, this is in keeping with my thoughts before that anything making constant sound stops the cutting out.

I have no idea what is happening or why, none of this makes sense.

EDIT 5: Sure enough, video ends, finish race, and the reward screens are cutting the audio again.

Idle on the menus where the most loaded core is core 0 at 50-60%, standard windows stuff, there are no audio issues at all. It is only when any individual core hits 100% and there is not existing constant sound playing.

I will test the ferrite choke idea as I found a cable, it is longer and thinner than the current one but has choke near the device end of the cable. That is a job for tomorrow as it is late, but at least I have confirmed some stuff and worked out when and how this seems to be happening.

New day, new tests, new set of confusion and YET ANOTHER I think I have fixed it… (Narrator: He didn’t)

Literally after testing the previous causes of it and them all checking out as I typed the word YET above it failed again…

So I tried changing the cable for another one with a ferrite choke on it and it completely refused to connect, it was getting power but no data. I though it might be that it was just a charging cable because that what I was using it for, nah it has all the pins, windows just refused to even try to connect it.

Swapped that for another cable and dame thing, I knew this one was a data capable cable as it was from a keyboard. Still no joy. It will not connect so far with anything other the the cable I am using right now.

I tried the front panel USB too and it was working perfectly, until just as I was about to type in here about it and it cut out again.

It is still tied to the 100% peaks on the CPU.

Now I am not sure if it is the Data lines getting the interruption or the power. I am willing to get a power filter for it to test but as always if I don’t have to spend money I would rather not.

Please help.

For now I cannot find any solution.

So the band aid fix is:

Just constant background noise, still no idea why it fixes it but it does.

So… More information. Having Discord open and watching a show with friends (constant sound) still cuts out. So certain games (Art of Rally and Need For Speed: Hot Pursuit Remastered) and Discord regardless of silence or sound will make the DAC cut out regardless of USB port used.

Simply having a YouTube or Foobar2000 playing anything will stop the cutting out.

TWIST: Turns out in some sort of a haze I must have gotten click happy and added another DAC to my cart on Drop (formerly Massdrop). A ddHiFi TC44B USB-C balanced DAC/AMP*. It is USB-C but with an exceedingly short cable unfortunately. It will take some time to arrive, it only estimates shipping to start on the 25th of January, so when that arrives I will try it and see what’s what.


This problem is very bizarre.

New Problem… 2.5mm and 4.4mm. WHAT THE FUCK WAS I ON! I have nothing that uses those sizes, I have never even heard of 4.4mm till now.

So it is too short for anyone to realistically use, needs and adaptor, does not even have onboard volume control and does not end up doing anything even remotely useful as a DAC/AMP as it supplies balanced outputs I can’t even use and lose all benefit of it if I get a converter to regular stereo outputs in sane sizes.

People give keyboard people shade but audio people are actually lobotomized.

I regret everything about this purchase. Like even existing to make it in the first place.

I’m very sorry for the late reply but I didn’t get notified about it.

I’ve gone through everything you did and it’s extremely weird what’s going on. What I’d say is that there’s some kind of incompatibility with Ryzen because I’ve had weird issues with USB. Even a basic UASP USB 3.0 adapter for HDDs kept disconnecting on Ryzen but worked fine on an Intel machine.

It’s surely not related to CPU usage because CPUs are so powerful now that since the P4 era I’ve never seen audio cutting out due to CPU usage (man GTA SA could lag the audio on P4s).

The frustration is real! I had to buy and send back two cases for my SFF build before getting the right one.

It’s a balanced output with 4 conductors in order to not have the two channels share one ground.

Have you tried disabling USB power saving into the system settings? That might fix it or improve the situation.

If nothing fixes it and you want to get a decent DAC the FiiO K3 is working superbly for me. I don’t suggest you those kind of portable DAC because usually the volume control is pretty bad, with large steppings.

Now that you mention it, I have had (only once since building this PC in november) my mouse wireless dongle plugged into the front panel USB2 port drop, that was 2 nights ago. I have also had my Steam Controller dongle drop twich in the same period, just replugging them fixed both with no oddness otherwise.

I don’t think it is because there is not enough power, I think it is more that the power draw and high frequency when a core hits 100% causes some sort of interference in the USB ports.

After all it will work absolutely perfectly when there is something on YouTube or Foobar200 playing, but certain games and Discord don’t show the same behaviour.

I believe I have, I usually make a point of changing those and when I updated the drivers from MSi’s site I did go back through then power plans as it updated the Ryzen Power Plan. But I will definitely check that to be sure.

I don’t even really care about the DAC as such, I got it to see if I could hear any difference between the onboard audio and something external processing it, I can’t. So a higher quality one, other than maybe helping with my issue (looking increasingly unlikely) would not be worth it for my use cases.

The uDAC3 actually has a very smooth and not stepped, as far as I can hear, volume control and is my absolute favourite thing. I hate tabbing in and out to raise and lower master volume. I would rather set them all where I like and them and turn it up and down with the volume knob.

Into the weeds:

This part, even in my posts, is a little off topic. I am more annoyed because buying through Drop means I have no return capability.

I think somewhere in the fog of a possibly alcohol influenced memory I bought this for my NUC which is/was intended as a music making PC. And that sort of made sense to me at the time… But that has optical digital outs on the back and a standard 3.5mm headphone port on the front. Seeing as I have no headphones or speakers that will take advantage of the balanced outputs it seems like a very stupid move now. Maybe in time I will make use of it but I really don’t know what I was thinking.

In the short term even if it is too short to be usable properly on my desktop, i can get a 2.5 or 4.4mm to 3.5 or 6.3mm adaptor and at least see if it helps with my Ryzen issues, if USB-C exhibits the same issues.

You mentioned that you wanted to see if pinning the CPU to 100% with light loads would make the problem worse. Maybe you could try to set the minimum frequency to 100% in the Windows power settings. Or doing the opposite, which is limiting the CPU frequency below 100% and see if the issue persist.

Because it has a volume knob. We just agreed on the same thing.

It’s fine if you need to vent a bit of frustration, I don’t mind that at all!

You can even get 2.5 to 3.5 adapters. They can be had basically all the sizes. I have a 2.5 to 3.5 one because I swapped the cable on my IEMs.

One last thing that I’m thinking of is: have you tried both USB connected to the chipset and USB connected to the CPU? I don’t think it might make a difference, but I’m really struggling to figure out what’s wrong with it. I wish I could help you more on the subject.

I will have to check a few things. Some games make it cut out at the same times it peaks 100% on any core, but I don’t think discord is that stressful so I will have to see if the cutting out there corresponds with the CPU also.

I was trying to think of an easy way to limit the CPU to 99% or hopefully not much lower to see and remembered seeing the setting just never tried it there. So that will be tested.

Ah yeah I misunderstood about the volume knob thing haha.

I will be likely picking up an adaptor sooner or later as it is completely unusable for me with out one or a scary expensive set of headphones.

While I cannot say for sure, I am pretty sure I have tired both in all the different tries but I will look up the diagram and see what’s which. Can’t hurt to try.

And thank you for try to help.

I have the same NuForce DAC as you and a couple of years back I started experiencing the same random glitches. It turned out to be a loose USB connection on the PCB.

Better cables helped a little, but in the end I enden up soldering an USB cable on the PCB and expoxying the shit out of it :stuck_out_tongue:

Now it works fine but it does not like the front USB on my case. I get random connection issues. I use it exclusively through the powered USB hub in monitor and it works flawlessly.

Yeah Micro USB has issues with losing its grip. I don’t think I have that yet, it is actually very tight on mine to the point I am always a little worried when I have to unplug it.

Edit: Though for whatever reason it refuses to transfer data with any other cable than the one that came with it, all the others will only power it.

There is an option I never considered. I have a monitor with the same thing. I can definitely try that. Thank you.