External build - Error codes (X99M Extreme4 MB)

MOBO: ASRock X99M Extreme4
CPU: Intel i7 5820K
PSU: 760W Seasonic Platinum
Memory: DDR4, 16GB (4x4), G.Skill Ripjaws
CPU fan: be quiet Dark Rock Pro 3
(for reference:
GPU: Gigabyte GTX 980Ti, 6 GB
SSD: Samsung 580 EVO, 500GB
HDD: Seagate Barracuda, 2 TB
CASE: Corsair Obsidian 450D, Mid-Tower
MONITOR: Asus VG248, LCD 144Hz)

Hey guys. A friend referred to this forum as the best and most helpful one, so I hope you can help.
[background] So I had a friend over and we put the rig together the two of us, but mostly it was him, then he had to leave. When I then started the computer there were several error codes at the MB (he didn't do an external build first), and at POST the screen with the option to go to BIOS settings didn't show.
Well, I cleared CMOS (hoping I wouldn't have to re-install the CPU or memory since it was all put together), nothing. [/]

So I decided to go to the basics, started from the beginning and made an external build (also had Newegg's guide up, to be sure to do everything right).
The error codes were 19, b7, and 76, 78 and 79.
I therefore re-installed CPU, installed only 1 memory, in the first module, and installed the video card. Removed CMOS battery to clear CMOS and waited 30 minutes to put it back.

Computer now powers on, and I am able to go to the BIOS settings, even booting to a USB with Windows works, but the same error codes at the MB are still there, and I don't fell like ignoring them.
Also, the SSD isn't recognized in BIOS if I boot with the SSD plugged in, but that's another problem I guess.

I've done the procedure again; re-installed CPU and memory (tried different memories, always only in the first module) and cleared CMOS. Booted the external build with only CPU and memory installed. Error codes persist.

Any idea what the problem could be and how to solve it?
Any help is appreciated, thanks.

Error code 19 is related to improper seating of the RAM, b7 is related to the DIMMs, 76 could mean your RAM is running outside of specification unstabley, and 79 means a drive has bad sectors and as such has failed. Go into the BIOS, enable XMP, and post your results.

Enabled XMP. I get error codes 19, 33, 62, and 79.
RAMs are seated correctly, could it be a MB problem at this point? Like, would it be worth it purchasing/trying another MB? Or is there another solution?

I'd get a refund and get something like the X99-M WS from Asus.

But it could very well be bad RAM at the same time however error B7 makes me believe not

Well code b7 no longer shows, only codes about memory (01-54) and chipset (61-91).
Thanks for the MB tips, should I try with new RAM first or just try a new MB?

If you're getting chipset errors as well... it could be a bad memory controller on the CPU as well... I'd like to say it's the board but I'm not 100% sure. It probably is however.

Load up Windows with Aida64 and run the cache and system memory stress test. If it fails, it's the processor's memory controller, if it passes, it is the board. Run that for around 4 hours minimum.

Thanks, didn't know about that!
Does Windows have to be installed for that though (since the computer doesn't recognise any storage drive to install it on)? Feeling like a real n00b here, but oh well :/

Yup. Maybe pull a drive from another computer

i would recommend to do a bios update first.