Explorer.exe crashing like symptoms!

so i've had an issue for awhile but only today have i found a way to describe it..

Visually it looks exactly like if explorer.exe in windows crashes or closes on you. If you don't know what this looks like head into your windows computer and open a few application like your web browser, notepad etc etc.

Then hit CTRL+ALT+DEL goto task manager , find explorer.exe and "END TASK" .. What you will be left with it is a desktop with no taskbar, start menu or icon but your application will still be functional and you can continue to use them and even ALT+TAB through them.

In windows you can correct this issue but going to FILE-> RUN in task manager and starting explorer.exe again , and voila! your desktop is back to normal.

So i've this exact same senario happen in linux, specifically ubuntu 14.04 with unity or gnome or xfce.

My apps are still alive but the desktop wallpaper disappears, dock, icons, taskbar (if applicable) etc.is gone..

any ideas fellow tech's on what could be the cause?

BUT most importantly how to fix it?

PS. a reboot fixes it but i want a more elegant solution.


Maybe a re install is necessary?

You've tried unity and gnome and xfce and they all have this behavior? If so that's really strange.

hmm seems really rare and nobody has chimed in anything really useful yet.

Let approach this another way perhaps, lets your GUI craps out on you.

How would you from tty1 reboot just the gui session in tty7 ?


It's only been 13h.

FYI with Ubuntu 15.04 and systemd tty1 should become the default graphical TTY. Anyway. From TTY service gdm restart I think that's the Debian way of doing things.

Or /etc/init.d/gdm restart
Or when you upgrade to 15.04 systemctl gdm restart

Hopefully I remembered that right. As for your problem I've had that with bleeding edge KDE when there is a but that crashes plasma-desktop its always smart enough to restart its self.

If you've not got much going on update to 15.04

(Sent from phone sorry for mistakes)

To add to what Eden said, some distros let you restart X (and therefore your desktop environment) with Ctrl+Alt+Backspace. This is disabled by default in recent versions of Ubuntu, however It can be re-enabled by setting the DontZap xorg.conf option to False or you can use the AltGr-SysReq-K key combination instead.

Its gone in almost every Linux distro, unless you use that flag. I've never bothered since it disappeared.

Yeah. I was (pleasantly) surprised it was on by default in my recent Linux Mint install, but the usage seems to be dieing out.