Existing hard drive Unknown & Not Initialized in Windows

I was writing some files few days ago to one of my mechanical hard drives and I got a device disconnected message. Since then the volumes of that drive disappeared from Windows. Now the drive is appearing as an “Unknown” and “Not Initialized” in Windows Disk Management tool.

The disk is not making any of the clicky noise that a failing hard drive makes. So I am hopeful this not a mechanical fault and either the fault is within boot sector/partition table or the logic board.

I have not initialized the drive in case I loose the partition table and the file index. It is a 1TB drive with two partitions. I tried using TestDisk as per Wendell’s guide but the drive does not appear to that software. My next best is to use ddrescue but I do not have a Linux machine available.

What do you guys think? Likely boot sector/partition table issue? The system event log has the following entries about the time the disk first got disconnected message from Windows.

20/08/2021 9:53:08 PM
Device SCSI\Disk&Ven_&Prod_\5&25248246&0&040000 was started.

Driver Name: disk.inf
Class Guid: {4d36e967-e325-11ce-bfc1-08002be10318}
Service: disk
Lower Filters: 
Upper Filters: 

20/08/2021 9:53:07 PM
Device SCSI\Disk&Ven_&Prod_\5&25248246&0&040000 was configured.

Driver Name: disk.inf
Class Guid: {4d36e967-e325-11ce-bfc1-08002be10318}
Driver Date: 06/21/2006
Driver Version: 10.0.19041.789
Driver Provider: Microsoft
Driver Section: disk_install.NT
Driver Rank: 0xFF0005
Matching Device Id: GenDisk
Outranked Drivers: 
Device Updated: false
Parent Device: PCI\VEN_1022&DEV_43C8&SUBSYS_43C81849&REV_01\4&288c77c7&0&010B

20/08/2021 9:53:08 PM
Device SCSI\Disk&Ven_&Prod_\5&25248246&0&040000 was not migrated due to partial or ambiguous match.

Last Device Instance Id: USBSTOR\Disk&Ven_General&Prod_UDisk&Rev_5.00\7&dc4866c&0&_&0
Class Guid: {4d36e967-e325-11ce-bfc1-08002be10318}
Location Path: 
Migration Rank: 0xF000FC00FFFFF120
Present: false
Status: 0xC0000719

If you want the data on this drive, you need to make an image of that disk onto another disk. Then work off the copy and see if you can repair the MBR/GPT.

Never write to a damaged disk that you want data from. You will go from a chance to no chance at all before you know it.


Yeah that’s what I though. I am imaging a live Debian USB atm to try and use ddrescue to image the hard drive.

Since you believe the issue is software and not hardware, once you have the drive fully imaged and if there are 0 errors during the read (100% recovery with ddrescue.) then you can try running parted on the drive and see if it can fix the issue.

At this point, you are using the image as your backup of the data. This allows you to try fixing the bare disk and you can simply restore the image and try again if you mess it up.

I would also recommend that you copy the image a second time so that you have always a state that you can copy and work on again if you think you or the software screwed something up. That way you don’t need to re-image the drive.

It appears the situation is worse than previously thought. The HDD did not get picked up by lsblk as a block device when booted into Debian. So I can’t really run ddrescue for dumping the data. Following is the only clue I could gather from dmesg

[   12.008026] ata5: softreset failed (device not ready)
[   22.020020] ata5: softreset failed (device not ready)
[   32.572025] ata5: link is slow to respond, please be patient (ready=0)
[   57.052024] ata5: softreset failed (device not ready)
[   57.052038] ata5: limiting SATA link speed to 3.0 Gbps
[   62.264028] ata5: softreset failed (device not ready)
[   62.264042] ata5: reset failed, giving up

I also noticed that the drive is not being recognized by BIOS as well as an HBA expansion card which I also plugged the drive into.

So if the drive isn’t being registered as a block device are my chances of recovering anything nil?

Going to try my luck with a SATA/USB interface now.

No luck with USB/SATA interface. I think there is not much I can do with the drive not being recognized even by BIOS! Fortunately I have a back up of some of the data, unfortunately it was about 6 months old and only subset of the data on the drive. Some files since then are lost it seems, although nothing terribly important.
I have all the important stuff backed up regularly to one place and weekly to another.
Nevertheless, I would like to recover what I can from this dead drive if there are any ideas?
My instincts say the issue is with the controller. Do controller transplants generally yield results?

You could use snapshots (e.g. LVM or ZFS) to make the original image read-only while being able to write changes to disk without needing enough space for two full copies.

You say it’s not recognized, but Linux clearly knows it is there, it’s just not responding properly.

If the platter or read head is not moving as it should, the refrigerator trick has a chance of working.

It is usually very difficult to find another hard drive with the exact same controller on it. That said, I have successfully swapped controllers, myself. In that case the controller went suddenly and completely dead, no power at all so it was obviously the problem. Mechanical failures of hard drives are far, far more common.

The drive spins up normally when powered up as I can tell by the sound. And there are no clicky sounds.

Yes the BIOS and OS know something is connected to SATA port but cannot detect it nor interact with it. BIOS hangs for a long time on boot when the drive is connected.

What is the refrigerator trick and how is cooling a drive supposed to help?

I wouldn’t bother with the fridge trick. That works if the bearings are seized up and you want to free them. Usually it works exactly once.

In your situation, it sounds like the drive head is no longer seeking.

If you want this data back, you are going to need to take it to someone who can open it and repair the mechanism.

The clicky clicky is the drive head moving back and forth. If it cannot do that, the drive will recognise as connected, but will not display any partitions for you to edit. This means the controller works, but some other part of the drive is not. If you hear it spinning up, then the bearing is fine, but the actuator for the drive heads might not be.

1 Like

I only use it when it is the last ditched attempt to get data off the drive before tossing it. Basically it can help with a bearing issue or with a head clearance issue. Sometimes platter warp issues but the condensation will eventually kill the drive for good, depending on how long or how many times you do this.

Pretty much this.

1 Like

I may have missed a mention, but have you tried a different SATA cable? Link issues being reported have been the cable about 50% of the time for me.

1 Like

Yeah I tired a different cable and also connecting to a different SATA port on an add on HBA card. Lesson learnt - don’t rely on SMART data to think the drive is ok.

This topic was automatically closed 273 days after the last reply. New replies are no longer allowed.