Ewaste X79 System Upgrade and Thoughts / Experiment


A couple of years ago when I decided to hop off of my 2016 5K iMac and get onto different hardware I set up a few parameters. The core of my system can only be ewaste finds and I want to see how good of hardware I can get my hands on at no cost. With that said I did buy a Corsair case, some fans and peripherals to support it. I started out with a OE Dell board (From an XPS) with an i7-2700 and a Radeon 2GB card that I forget the model of already.

Originally I started out with a Sandisk SSD and a 2TB Barracuda from ewaste but I’ve since made the decision to purchase a 1TB Samsung EVO 960 and a 4TB Seagate Barracuda. I also have a 2TB Firecuda from ewaste (pretty sure it was someone’s cold spare because it had nothing really written to it and next to nothing (outside of factory norm) for head spin hours attribute).

Since then I was able to upgrade to an ASUS Z77 board and an i7-3770. I ran this configuration for almost 2 years already! I upgraded the GPU to a 1660 Ti which while not ewaste was an Amazon mess-up and they didn’t want it back so I got to keep it (perks of running a brick and mortar shop). I certainly loved the platform. I was able to OC to 4.5GHz all core stable. I had 32GB of PC3 (Low Voltage) - just generic 8GB Crucial modules. I have a Noctua NHC14 (also ewaste!) which is by far my favorite cooler design.

Recently I received a gift from the ewaste gods in the form of a control module from a factory. I am pretty sure this was a cold spare as well because usally industrial components are filthy with grease and grime. It was kind of an oddly shaped case which as I understand slotted into a bigger machine and was it’s controller. Inside was a standard computer (like usual). However this “standard” computer was an amazing find.

The computer was an MSI X79A-GD45 board with an i7-4930K and 16GB of PC3.

I brought my computer into the shop the next day and started swapping out my parts. Sad to see the Z77 board go but I am very excited to see what 6 cores / 12 threads is all about!

The more I read about this board (combed through the manual and read a few posts on it), the happier I am with the find. It is surely a feature rich high end piece of hardware for the time.

It has plenty of USB 2 which is nice because I have a lot of peripherals (different mice/keyboards, drawing pad, controllers, etc.) and seems to have a nice assortment of audio options. I am a fan of the TOSLINK to my DAC. Not sure that I’ll make use of the OC Genie stuff as I prefer to manually configure in BIOS but it is neat to have and I’ll definitely experiment with it. I like that there’s a physical dual bios switch.

So I got to work and I swapped everything out. I grabbed a marketing sample 5700 XT to experiment with over the holiday weekend as well. I have mostly only used Nvidia products but this 5700 XT was just collecting dust and I wanted to put it through its paces before I sell it off (discounted as used of course).

So this is the system put together. I do have a cheap set of PSU extension cables I am testing before I pull the trigger on stocking them as well. They’re something like 12 dollars from the distributor. My Power supply is a 650W Thermaltake Smart which is another technicality. It was pulled from ewaste but I was able to RMA it so I have a “new” one.

My only challenge in the build was getting the Noctua to fit on the X79 socket. I am not sure if it originally came with hardware for it or not. Unfortunately the mounting hardware for the Z77 doesn’t quite translate. I experimented with an (ewaste) EVGA 240Ml AIO but didn’t have the right hardware and couldn’t get reliable mounting pressure. I did find that a Hyper212 I have had the right hardware and upon experimentation I utilized some of those parts to get the Noctua to fit.

The mounting system for the Noctua worked perfect with these modifications. Their long screw with spring retaining mechanism worked a treat. I tested with paste spread and found the right fit. So far my thermals are in check. Seems to idle on desktop around 30C which seems appropriate (though not entirely familiar since this chips is (according to ark 130W TDP whereas the 3770 was like 75ish)).

My other “Challenge” was ram. All of my modules are DDR3L and none of them seemed to boot the machine. I ended up using the 2x8GB modules it came with. They are 1600MHz so not a bad place to start. I’d really like to get back to 32GB but that’s just a nice box to check not a necessity.

I was very pleased to find that Ubuntu (20.04) booted up right away (after some tinkering in the bios of course) without issue. I have the reinstall and Home / files swap down to a science but it’s always nice to skip that. I was also pleased to find the 5700 XT up and running with the newest drivers without any configuring as well. I was fully expecting there to be problems.

So far I’ve just done some minor tweaking of the CPU in BIOS but I’m really just getting a “baseline” for now. So far I haven’t really done anything to see any advantage in the new configuration. My current game has been my Minecraft Realm with my friends we’ve been developing for a couple of months. Otherwise I’ll take Doom Eternal for a spin again and see (Before I had no problem with Vsync 144FPS 1080 Ultra). I’m considering changing monitors at some point but right now I just have 3x 27" 1080 panels - the primary a Dell 144Hz. I’d like to try an ultra-wide at a higher resolution.

So now I have a couple of challenges ahead for my tinkering.

  1. I’d like to see if I can get PCIE booting. I briefly tested this with a PCIE - M.2 Adapter and a couple of drives (a Patriot, a Samsung OE (HP) and a Kingston). So far I haven’t been able to boot from them but I haven’t lost hope. With the dual bios switch maybe I can use a utility to modify a bios image to have the NVME capabilities with little risk to bricking the system. Else the MSI compatibility chart does show some PCIE devices so I know its possible. Maybe there’s some settings or maybe I can find an older more compatible drive. I haven’t tried my Sabrent Rocket 4.0 yet or my 950 EVO.


  1. I want to see how much of a clock I can give this chip for all cores stable. I am hoping I can get around 4.3.

  2. Potential clock play with the 5700XT.

  3. See if I can get my Tesla K40 working with this configuration. Just a curiosity not a production need.

  4. Get a hold of some high speed memory. According to the compatibility chart on MSI’s website there are models of PC3 that can clock as high as 2400MHz. That would be neat to test but I’d be happy with 32GB of 1866.

So far in my normal usage everything seems to be going okay. Like I said I really haven’t done much to find a difference from my old configuration but Its just exciting to have “new” hardware. The only thing I’ve kind of noticed is some hiccups on the desktop which may be due to switching video cards but I’m still investigating. I occasionally have strange abstractions with “blur” or “shadow” and transparencies and the occasional stall while typing. May try doing a fresh install of Ubuntu or something anyway.

I still have to update the BIOS. I did a cursory glance and it’s on an older revision. MSI’s website seems to only offer EXE executables so I’ll have to dig around for something I can just put on a fat drive and flash from bios.

Edit: One other peculiarity I found was it doesn’t seem to play nice with fan splitters. One of the cables I was using which is a standard 2-1 pwm cable from StarTech only seems to be powering one of my 2 corsair 140mm front intakes. Hmm. Will investigate.


I’d be careful with the memory, apparently it is pretty easy to fry the memory controller on these chips when overclocking.

It is 100% possible to boot nvme on these boards. I have a x58 system booted into Windows on an nvme drive. Look into chainloading into a uefi image, which then boots your os from the nvme. Or get a nvme drive that has a bios compatible optrom, a samsung 950 pro was popular if I remember correctly.

1 Like

Be aware that some specific Prime95 FFTs are less stable than others and even FFmpeg on Linux causes a lot of VRM noise. Reaching 4.3 will depend on how much you can control the noise from your VRM.

(6:55 of this video is what noisy FFTs look like)
1 Like

2400MHz ram wouldn’t be for daily use I’d just like to get my hands on a kit for curiosity sake.

I’d seen some options out there like the Clover EFI like they use for Hackintoshes. This kind of play is new to me. Good to know about the 950 EVO Pro that’s the one I have sitting around. Cool to hear your report of having pcie boot work on x58!

Hey, neat video! I haven’t gotten a great deal into this board yet but it does have some nice features like led indicators on voltage lines. The power delivery system certainly looks robust to the eye but we shall see. Now I gotta look at how to hook my oscope up to this XD that seems like a neat project on its own. It does have (unpopulated) serial debug headers I could try to listen to as well for what that’s worth. If this board/chip doesn’t clock that well its okay.

I don’t actually do anything that intensive anyway. Hell I ran my 2006 Mac Pro on dual quadcore 3.2 GHz Xeons for YEARS before switching off of that platform. I felt limited once I could only be on El Capitan (FW UPDATE + modified 32bit efi) (the DDR2 was a sore-spot too but that could boot to PCIE using an adapter and a MacBook’s Samsung drive which was amazing for how far you could stretch that old hardware).

1 Like

Update Log:

So I have successfully gotten this board to boot to PCIe. I am using a generic adapter (PCIe to M.2) that I got from Amazon for sub $10. With a Sabrent PCIE Gen4 Rocket it did not show up in BIOS, nor Samsung 960 EVO, one from PNY or one from Kingston. (Can Post their models next time I’m in shop if anyones interested.) The NVMe (and I stopped tested after this one worked so I may have some other models that work) that worked for me was the Samsung 950 EVO PRO 250GB. This was exciting to see it show up as a boot option. I also checked to see if I could manually map to EFI on the other drives but could not see them. I certainly could see them in OS so they would work was data drives just not Boot.

I also snagged 4x8GB HyperX PC3 1866 modules. They are not PC3L so they’re the full 1.5V which I think works better (in my limited testing) on this platform - though the data sheet does suggest PC3L models should work. With these HyperX modules I was able to boot right away and even set their clocks without issue.

I went back to my GTX 1660 Ti - the 5700 XT worked fine but for my uses it was a lateral move. Most of my gameplay and desktop applications saw no difference. I’ve really only been playing a handful of fighting games (Guilty Gears, Melty Blood, Tekken 7) and Minecraft. As far as desktop applications goes its like Libre Office, Firefox, Krita, GIMP, Inkscape and some messing around with Godot.

I decided to do a fresh installation of Ubuntu 20.04 and all is well in my little world. I put the EFI and system partition on the 950 EVO PRO and my Home partition on the 860 EVO 1TB drive. Everything is running smooth, no issues with hickups or stuttering. I have the CPU clocked at 4.3GHz and the ram at 1866. In fact the annoying Firefox video tearing has gone away too not sure if result of system or driver update or something with Ubuntu’s compositor.

I’m pretty happy. Might be interested in doing a sound card but right now everything sounds good to me. I am by no means an audiophile and I just run off the motherboard’s Toslink to a cheap dac on my desktop.

Still haven’t messed around with my TESLA card yet. Not sure I am up to it after all of this tinkering. Might just build a different system around it or try to get it working in ESXI on my Lenovo X3650 M4 again.

I also might try implementing my ASUS Hyper M.2 X16 Card. I couldn’t get it to work in my server, it just appears to pass through 1 of 4 NVME drives in it. Might be a chipset thing? One of those projects I just plugged in, didn’t work right away so I shelved it.

I also “Upgraded” my temporary 1TB WD Black with a 2TB Firecuda for my steam drive. Normally I am allergic to Seagate but the WD Black was a stopgap solution (it’s like a 5 year old drive that I pulled out of a workstation). The 2TB Seagate Firecuda was free so yea. I had one little issue with it at first. I used a hardware cloner to clone the WD to the Seagate (was also testing for use in shop). When I got into OS I saw which was expected that it had 1TB of space file system with my steam library and the other TB was unformatted. Using Ubuntu’s DISKS program (Gnome Disk Utility) I couldn’t expand the existing file system - it kept returning an error , or attempting to do it and just sitting there forever. I tried running it as sudo and I attempted it in the terminal. It wasn’t until I went to reinstall Ubuntu that I was able to expand the filesystem from the USB loader. Oh well. I am still a huge noob XD


The reason it doesn’t work for the other 3 drives is because the BIOS has to tell that slot to bifurcate from 1 x16 to 4 x4 lanes. That doesn’t really exist in X79.

Going to need a hacked bios to enable bifurcation on x79. The hardware knows how to do it, but the capability is hidden by software.

This topic was automatically closed 273 days after the last reply. New replies are no longer allowed.