Even's stunning BSD adventure - The BSD challenge blog

Noooo. :frowning: you make me look bad OP. You downloaded the iso and then started out to carry out the challenge.


1 Like



Sorry, but I have to keep this train going, I’m too afraid of @AnotherDev. He does not call 911 you know…


Force Composition Pipeline

does it for me on loinux. this is what it generates:

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 418.56

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"

Section "Files"

Section "Module"
    Load           "dbe"
    Load           "extmod"
    Load           "type1"
    Load           "freetype"
    Load           "glx"

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "BenQ GL2460"
    HorizSync       30.0 - 83.0
    VertRefresh     50.0 - 76.0
    Option         "DPMS"

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 780"

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-1"
    Option         "metamodes" "HDMI-0: nvidia-auto-select +1920+0 {ForceCompositionPipeline=On}, DP-1: nvidia-auto-select +0+0 {ForceCompositionPipeline=On}"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24

Not sure if this will help on BSD


That Nvidia settings manager is exactly what I’m looking after, that fixes screen tearing on my linux machine too. For what ever reason I can’t open it up either on MATE or KDE. I’ll try to edit the configuration file manually little later.

Anyway, some progress:

  • :white_check_mark: Urxvt works, tough I have to run xrdb ~/.Xresources after rebooting the system. Have to do some digging, It’s been while since I last time messed with Xresources and configured Urxvt. I actually thought my old .Xresourses config file was breaking things, but happy to notice that’s not the case. Dat lovely color theme tho? :blush:
  • :white_check_mark: KDE dark theme. :ok_hand: I don’t bother to rice that much since I’m going to bulldoze this thing to the ground sooner or later.
  • :white_check_mark: Waifu pape. Keeps normal people at safe distance. :wink:

To-do: Urxvt can only be launched from terminal, hence why I have Konsole running too. Have to set urxvt as default terminal so that I can open it with simple keyboard shortcut.


I’ve speant barely anytime on my GhostBSD machine since installing (Work & family take priority) but @redgek suggestion fixed the screen tearing for me too.

I did discover that the nvidia driver install is tied to the Linux core 6 packages that are installed. I updated my packages to c7 which uninstalled the c6 packages - and the nvidia drivers along with them :sweat_smile:

Easily fixed once I realized what had happened, but a WTF moment after a rebooting the day after doing it and forgetting what I’d done!


These are the moments that are most informative learning experiences for me. While at the uni I read f ton of academic journals and articles, but for what ever reason I’m really lazy to read any software documentation when tinkering with things. I will eventually read and realize the answer was there the whole time and I just used two hours of banging rocks together. :smiley:

As a side note, I started to look up some used Thinkpads yesterday. This Asus laptop really isn’t fun to play with, and I can’t justify to myself for upgrading ram or SSD to this if the damn thing can’t even output 1440p resolution. T440p looks nice, with quad core cpu and ability to put two SSDs in that could be really nice machine, but I couldn’t find any well priced units from Ebay. I did find some x230 machines tough. :thinking:


Regarding the tearing and nvidia’s control panel acting up, is there an option along the lines of ‘full screen repaints’ in the default KDE display settings?


I checked and there is. Unfortunately it does not fix the tearing. My best bet is to just tinker with Nvidia drivers and try to the tearing that way.


Well I got side tracked and installed Manjaro to my desktop, and under linux I was able to fix the screen tearing and stuttering with a combination of @redgek’s config, my own config file that I was able to generate with nvidia-settings and some some healthy amount of frustration and screaming at the computer.

I’ve also been messing around with GhostBSD a little. I tried to figure out how to install Discord and Spotify, but the guides I tried didn’t work. Then again those guides are for FreeBSD, and I have no idea if they are supposed to even work since GhostBSD is TrueOS based. Or that’s what Wikipedia says. GhostBSD website is only mentioning FreeBSD. Most likely reason is I have no idea what I’m doing, but hey, this is a learning experience. :stuck_out_tongue:

Yesterday I was cleaning my old room at my parents old apartment. They had this old HP Probook 4320s in living room, serving as a HTPC since they don’t have smart TV. Well they didn’t have any use for the HTPC anymore, so they asked if I have any use for it. Well, I can think at least one thing what to do with this machine. :smirk:

Let’s install FreeBSD!

I don’t have much time today for this, so this might have to wait until weekend. But still it’s nice to have new hardware to play with.

I also have some old 2004 Fujitsu laptop with Intel Pentium M and 512mb ram in it. I could dust off my tinfoil hat and install OpenBSD. If I can replace the dead HDD with SD card. :thinking:


Well I totally lied, I did install it.

Let’s see if I manage to configure this and get KDE or i3 running. It wasn’t promising sign that I couldn’t even sudo after I got freeBSD installed. :smile:


Started playing with with FreeBSD again today. I tried using this video guide, but unfortunately I couldn’t get KDE to work. I have to investigate what’s going on. While following that guide I feel that guy left some things out.

Currently the installation flashes the command line login screen. :thinking:


You can do it @Even747-San!

1 Like

Is sddm installed?

If so, does /etc/rc.conf have sddm_enable="YES" ?

Is your user part of the video, wheel, and/or operator group?


It is, and I checked rc.conf and sddm is enabled. Still have the flashing screen :confused:



Graphics drivers installed?
X.org installed?

Does /var/log/Xorg.0.log say anything?

Have you generated a X.org file?

Xorg -configure
sudo mv xorg.conf.new /usr/local/etc/X11/xorg.conf.d/xorg.conf

:point_up: Capitalize the X in the first command and only use 1 hyphen, I believe.

1 Like

My lucky guess is the graphics drivers are not installed. X.org is installed.

If I have extra time tomorrow I’ll reinstall the whole thing and try installing graphics drivers and test your other suggestions.

I was supposed to be in bed hour ago. Fug.


KDE is quite large package, maybe I should use VM instead and save snapshots on regular intervals if I f up something :smiley:

Anyway, after I get KDE and SDDM packages installed I go to bed and continue later.


Just status update:

Got tired of playing with my laptop. It’s probs almost 10 years old already so I wouldn’t be surprised if the GPU in that thing is cooked or something like that. In any case I didn’t get KDE to work on that machine, so I’ll try VM next.

Got FreeBSD working in Virtualbox and took snapshot from the base system. Now I don’t need to reinstall everything all the time if I make mistakes during the journey. :stuck_out_tongue:


So updates on my BSD adventure. I tried and succeeded at setting up web server with FreeBSD 12.0. I was about to post short guide about it here, but it got way longer than I initially planned and decided to make separate thread about it:

Guide: Setup basic webserver using FreeBSD and Nginx


Learned a lot of stuff while doing that and can recomend it to others too. Let’s see if I find some time to start playing with FreeBSD in VM soon. Would really like to try and run BSD as a daily driver for a while. :slight_smile: