Ethernet Drivers Not Installing Properly

Hey guys, so one problem solved, but now another arises. I was having problems getting my ethernet cable to work and then I was told to download my motherboard's drivers here ( 64)

I did that and tried to install them. The install seems to work fine, but it is still not working... could someone walk me through how to install that ethernet driver?

Or if that isn't the issue, could someone propose some ideas about how I could fix this?

Assuming that you've diagnosed the network adapter and done all the basic troubleshooting and the driver is for YOUR motherboard and you picked the right operating system and everything in the drop down menu, the installation should be done in a double-click :/

I know where i'm seated my computer just won't communicate with my router if i run 100mb/s or more on my network card, so i set it to 10mb/s full duplex.


But as you may have multiple network adapters, the priority may be wrong (programs like hamachi can screw you over in this area), type "Network Connections" in the start menu OR (Network and Sharing Center -> Change adapter settings).

Now check which adapter you think your network cable is connected with, and click "advanced -> advanced settings" in the toolbar in the top of the "Network Connections" window. If the toolbar doesn't show just press the "Alt" key and it will appear.

Here your suspected cable-connected adapter should be at the top (if there are multiple) use the green arrow keys to the right to navigate them up and down.To change the duplex speed. While in the (Network Connections window) right click the network adapter that the cable is connected to and select properties. After that click "Configure" in the new window.


In this new window you should have a lot of tabs, find one named "Link Speed" and select the 10 mb/s full duplex, see if that helps. If it doesn't, just turn it back to what it was and be forever doomed.

No but if nothing helps, pray that you have the CD that comes with the motherboard, i always save it x)

If none of my suggestions worked, you can uninstall the driver by typing "device manager" in the start search field, go to network adapters right click the intel ****** driver and select properties, there you can uninstall it. Then try to reinstall the new drivers again.