Ethernet Driver not recognized Debian 7 (MSI Z97-G45)

Finally got Debian up and running on my MSI Z97-G45 but w/o ethernet support! It warned me during install but I thought I might be able to install from # apt, but alas no. I am able to use my GS3 as USB wifi tether but this is a temp fix. I tried packet mg and update but this too = fail. Any advice? the actual chip is the qualcomm atheros e2200.

You need to install the killer ethernet driver which is unfortunate as linux has not reverse enginered that yet. If you wish to continue with Linux I suggest you get an Intel drop-in card

1 Like

I tried this workaround but when I get to this step
{make defconfig-alx}
it tells me no such command exists or some such thing, ( I should I wrote that down).


Have you tried to run the whole sequence as root? I.E: sudo -i then make defconfig-alx

Or if you like, just install a newer kernel, the alx module has been in the mainline kernel since 3.10 and so any kernel above that should have it and it should work. Though I would suggest you install the kernel 3.15+ for best results.

Also, I'd should mention once you get the driver installed, set your MTU to 8192 or you're packets will get dropped, it's a bug in the module that needs to be addressed. I have the ALX module installed on my Arch box and the problem seems to persist across all distros.

Is @rollymaster correct? Is this a killer nic? If that's the case just don't bother with it and buy an intel nic.

Those NICs are junk on anyrhing but windows because they're essentially software NICs with some fancy windows drivers. On Linux they don't work very well, drivers exist but their perfomace is poor.

Buy an Intel nic. You'll be much happier.

Do you have make installed?

sudo apt-get install make

Thanks all, I'll try all that but I know Ubuntu runs well w/o much tinkering so I might just go that route if all else fails.

I'd try Ubuntu 14.04+ as that has a newer kernel with alx driver. But I'd set your MTU to 8192 or you'll have problems. Like I said earlier, the issue with MTU is a module issue that has not been addressed. ;) Hope it works out better.