Error at Startup "Verifying DMI pool data.." Freezes

My friend recently did a BIOS update for his old Acer T180, and after rebooting, a black screen with white text appears, as usual, but it pauses at "Verifying DMI pool data.." with a flashing underscore at the end of the message.  It could just be a hardware error, E.G. a misplacd cable, or god forbid the BIOS chip is fried.  I can still get into the updated BIOS and make and save changes perfectly fine, but after exiting the BIOS and even after resetting the BIOS to default settings, the message pops up after a few small things that go by too fast to read.  Any solutions?  Help is much appreciated.  Thanks in advance, guys and girls!



try to tke out power cord from the psu, and take out the bios battery.. so that its resetted, to real factory defaults, then  put back the battery, and the power cord, and try to boot up then.

wenn you still get the same error, then i guess your bios is briked.

if he has an unboard video chip, and a gpu card, try to take out the gpu card, and connect the unboard video card,  can also be a problem with hard drive, but i dont think so cause before biosupdate i think everything was  fine?