Return to Level1Techs.com

Enforce [email protected] - turning MST off?

Hey guys, I am trying to navigate through all the possibilities on the internet to enforce 4k 60Hz on my Asus PB287Q which is capable of pushing [email protected] (GTX 1070).

However, it looks like a typical EDID situation. Following the instructions on Reddit was unsuccessful as some of it was unclear! (See “set MST=off” option - when, and where? )

I am rocking latest Ubuntu LTS with Nvidia Drivers.
Peter.

ah it looks like I need to switch to DisplayPort. This monitor doesnt support HDMI 2.0, but HDMI 1.4 & DP 2.0.

HDMI is also a very shaky situation with Nvidia drivers. It technically doesn’t “Hotplug” HDMI 2.0. DisplayPort supports display hot plug a lot better on Nvidia drivers.

You may have to tweak the nvidia meta modes. This is what I did to fix screen tear but I used the same approach to force my display to run at 4k 60hz.

Launch nvidia-settings GUI, enable ForceCompositionPipeline and ForceFullCompositionPipeline for each monitor and apply.

“Save X configuration file” --> “Show Preview” --> Find metamodes in the X configuration generated from the newly modified nvidia-settings.

"metamodes" "DVI-D-0: nvidia-auto-select +1920+0 {ForceCompositionPipeline=On, ForceFullCompositionPipeline=On}, HDMI-0: nvidia-auto-select +0+0 {ForceCompositionPipeline=On, ForceFullCompositionPipeline=On}"

Get CurrentMetaMode from nvidia-settings

nvidia-settings --query CurrentMetaMode

Assign CurrentMetaMode manually to enable ForceCompositionPipeline and ForceFullCompositionPipeline for each monitor. For multi-monitor setup you will need to specify this for each display.

nvidia-settings --assign CurrentMetaMode="DVI-D-0: nvidia-auto-select +1920+0 {ForceCompositionPipeline=On, ForceFullCompositionPipeline=On}, HDMI-0: nvidia-auto-select +0+0 {ForceCompositionPipeline=On, ForceFullCompositionPipeline=On}"

Launch “Session and Startup” --> Add the above command to Application Autostart.

Reboot.

Get CurrentMetaMode from nvidia-settings and check that the new settings have been applied.

nvidia-settings --query CurrentMetaMode

Sources:
https://wiki.archlinux.org/index.php/NVIDIA/Troubleshooting#Multi-monitor
https://askubuntu.com/questions/989746/edits-to-nvidia-xconfig-not-taking-hold-after-restart
https://discourse.ubuntu.com/t/ubuntu-19-04-and-nvidia-settings/10580/12