Enable ADB without consent from the device?

I need to use ADB to access my system partition. Unfortunately I can't enable ADB from my device itself. Is there a command or way to enable ADB? I kinda stuck in the boot at the moment and ADB recognizes the device. I REALLY need to fix this. Thank to anyone who can help me.

I don't know if this will help, but here's my situation:

C:\sdk\platform-tools>adb devices
List of devices attached
D0FBA0A0407201E0 offline

I'm getting somewhere. Anyway to run this from my computer and have it executed on my device?:

echo 1 > /data/property/persist.service.adb.enable

Edit: Dammit:

C:\sdk\platform-tools>adb shell "echo 1 > /data/property/persist.service.adb.enable"
error: device offline

Edit 2: Is there a force command or something for ADB? If I could force the command above to run, I'd be golden.

I'm getting the impression that someone is watching this post and laughing at it :) (what's this dumba*ss trying to do). I don't know what I'm doing in all honesty. I should just be able to export a command to the ROM like I can on a live Linux CD to a Linux distro on a hard drive.

Try getting the device in recovery mode and thy to execute the commands there. Also you cannot modify the file if your abd shell is not rooted.

I am rooted.

But you have to allow root access to ADB.

Also try adb logcat and wait if it will do something. Also update ADB to the latest version if you haven't already.

How? Without access to the GUI I don't know how. I tried adb root, but got nothin except an error.

Done and nothin


Fixed it:
Apparently resetting the device gave me temporary root permission on first boot, however each time you want to modify the partition, you must factory reset. I'm laughing over here. I'm so freaking happy it's unreal. Now I don't have to dish out for another tablet. Thanks @krusic22 For trying to help me.