Emulating Sly Cooper & Game-breaking bug

Hey guys,

I've not got much hope for this one, but here goes.

i've been trying to play the first Sly Cooper game (Thievius Raccoonus) with PCSX2. Before you bother asking, yes, I own it. I don't want to dig the console out and hook it up to some screen or other and maybe find that it's broken, etc. 

Anyway, so I've encountered a game breaking bug. This bug is apparently previously known; it's supposedly triggered when you use a non-Sony memory stick or a GameShark. What happens is that, first, the game considers your key count to be 1 less than it should be, and second, some (apparently random) grab-able objects just silently break and can't be activated.

I've tried everything I can think of. I've turned off speedhacks, I've turned off HW hacks, all the antialising options, 16:9, etc, and I also changed from the virtual memory card I was using initially to the "standard sony" size. 

Any suggestions?

It's most likely a bad rom and nothing else. just get a new one and import your save


Giving that a try. Will update the thread later with whether it worked.

Unfortunately it did not work. Any other suggestions?