Return to Level1Techs.com

Egl:multisample=yes doesn't work for me

Hi all,

For some reason, in the past few release candidates (and bleeding edge builds), I’ve noticed that if I leave the default setting of multisampling for the EGL renderer set to on/yes, I get the error of:

Could not create an SDL window: Couldn't find matching GLX visual

but if I set it to off/no, it works fine.

Not sure if this is an issue with my configuration or not, but my setup is as follows:

  • Arch, 5.8.5
  • VM with a NVIDIA 1070 passthrough to Windows 10
  • CPU is an Intel i7 6700k (so the iGPU is for the host)
  • not using Spice (Barrier for mouse/keyboard and ich9 audio)

The last time it worked without this specification was back when EGL was just beginning to be supported… so I don’t know why this is the case.

Thanks for any help or advice.

Mutlisample is a hardware feature that your GPU doesn’t support, which is why this option has been provided. Early versions of EGL did not use Multisample.

Oh well that’s easy enough. Thanks for the quick help! :slight_smile: