Return to Level1Techs.com

Dumbest/Funniest mistakes you have ever made on BSD/Linux/UNIX


#101

ha-ha-ha that reminds me of when our boss was using dos 5 and we ran a small version upgrade (he left the office to go to the bathroom) and when he was out I changed the prompt message to
“I’m Ready to take over your mind human!”
lmao man was he a paranoid screwball
I told him i could fix it and it would take a while so he went out to the lounge to do his paperwork while i corrected it and spent the rest of the afternoon goofing off


#102

This morning I was playing with mozilla’s deepspeech on my ubuntu laptop and got an error message that it could not access my microphone that was already in use by pulseaudio.

I had no idea what pulse audio was so after “dpkg -l | grep -i pulse” showed several installed pulseaudio and libpulse packages, I did the only rational thing to solve my microphone error:

sudo apt-get remove libpulse* pulseaudio*

and of course I did not pay any attention to the dependencies that were also about to be removed.

Fortunately once you nuke your desktop environment, you can still get to /var/log/apt/history.log to discovery what apt-get tried to warn you were going to remove:

Commandline: apt-get remove libpulse* pulseaudio*
Requested-By: clifford (1000)
Remove: speech-dispatcher-espeak-ng:amd64 (0.8.8-1ubuntu1), speech-dispatcher-audio-plugins:amd64 (0.8.8-1ubuntu1), unity-session:amd64 (3.28.1-0ubuntu3), ffmpeg:amd64 (7:3.4.4-0ubuntu0.18.04.1), gnome-control-center:amd64 (1:3.28.2-0ubuntu0.18.04.2), speech-dispatcher:amd64 (0.8.8-1ubuntu1), libgegl-0.3-0:amd64 (0.3.30-1ubuntu1), libespeak1:amd64 (1.48.04+dfsg-5), libpulsedsp:amd64 (1:11.1-1ubuntu7.1), pulseaudio:amd64 (1:11.1-1ubuntu7.1), libqt5multimedia5:amd64 (5.9.5-0ubuntu1), ubuntu-session:amd64 (3.28.1-0ubuntu3), gnome-orca:amd64 (3.28.0-3ubuntu1), ubuntu-desktop:amd64 (1.417), gnome-settings-daemon:amd64 (3.28.1-0ubuntu1.1), indicator-sound:amd64 (12.10.2+18.04.20180420.3-0ubuntu1), gstreamer1.0-plugins-bad:amd64 (1.14.1-1ubuntu1~ubuntu18.04.1), unity:amd64 (7.5.0+18.04.20180413-0ubuntu1), orca:amd64 (3.28.0-3ubuntu1), gdm3:amd64 (3.28.3-0ubuntu18.04.3), libfluidsynth1:amd64 (1.1.9-1), unity-control-center:amd64 (15.04.0+18.04.20180216-0ubuntu1), gstreamer1.0-pulseaudio:amd64 (1.14.1-1ubuntu1~ubuntu18.04.1), unity-greeter:amd64 (18.04.0+18.04.20180314.1-0ubuntu2), libespeak-ng1:amd64 (1.49.2+dfsg-1), gimp:amd64 (2.8.22-1), libpulse0:amd64 (1:11.1-1ubuntu7.1), libpulse-mainloop-glib0:amd64 (1:11.1-1ubuntu7.1), indicator-bluetooth:amd64 (0.0.6+17.10.20170605-0ubuntu3), libpcaudio0:amd64 (1.0-1), libcanberra-pulse:amd64 (0.30-5ubuntu1), libsdl1.2debian:amd64 (1.2.15+dfsg2-0.1), libavdevice57:amd64 (7:3.4.4-0ubuntu0.18.04.1), libsdl2-2.0-0:amd64 (2.0.8+dfsg1-1ubuntu1.18.04.1), gnome-initial-setup:amd64 (3.28.0-2ubuntu6.16.04.4), libasound2-plugins:amd64 (1.1.1-1ubuntu1), remmina-plugin-rdp:amd64 (1.2.0-rcgit.29+dfsg-1ubuntu1), pulseaudio-module-bluetooth:amd64 (1:11.1-1ubuntu7.1), unity-settings-daemon:amd64 (15.04.1+18.04.20180413-0ubuntu1.2), gnome-shell:amd64 (3.28.3-0ubuntu0.18.04.4), unity-tweak-tool:amd64 (0.0.7ubuntu4), pulseaudio-utils:amd64 (1:11.1-1ubuntu7.1), libfreerdp-client2-2:amd64 (2.0.0~git20170725.1.1648deb+dfsg1-7ubuntu0.1), libfreerdp-plugins-standard:amd64 (1.1.0~git20140921.1.440916e+dfsg1-15ubuntu1), mutter:amd64 (3.28.3-2~ubuntu18.04.2)
End-Date: 2019-02-16  07:54:45

And after enough time with sed that it would have been quicker to edit the list by hand:

[email protected]:~$ sudo apt-get install $(tail -n 2 /var/log/apt/history.log) | head -n 1 | sed 's!Remove: !!g' | sed -e 's!:[~+[:alpha:][:digit:] /:().-]*,*!!g')

got me back into a desktop. And now I know gnome depends on pulseaudio, whatever pulseadio happens to be.


#103

Pulseaudio is your sound server, typically you wouldn’t want to remove that, for quirks like those btrfs snapshots come in real handy :wink:


#104

My laptop is bravely rocking ext4. Although /home is on a separate partition that rsyncs nightly to a network share. I am glad apt logs in detail my shameful requests and their consequences.


#105

This was gonna be mine. Also “at least once”. :rofl:


#106

I did the only rational thing

sudo apt-get remove libpulse* pulseaudio*

I see your problem!

You forgot the --purge flag. :sunglasses: