Return to Level1Techs.com

Dumbest/Funniest mistakes you have ever made on BSD/Linux/UNIX


#81

Tried to do a distro upgrade of Linux Mint (15->17). Then I realized my mistake and promptly nuked Mint and installed OpenSUSE


#82

My mom needed to email a bunch of pictures and I told her to just zip it and upload it to google drive so she could just send the link to whoever she needed too, so she had me do it after I had been drinking. Nailed it! every picture got put into their own nice little zip... Yeah that took a few minutes of pondering to unzip 108 pictures while being that drunk. I have had a lot fun playing with the cli while drunk.


#83

Zypper rm nautilus

I wanted to run nemo as my default. This was not a mistake so much as it was just pure experimentation, but I did not want it to delete ALL of gnome.

I still do not know how to force delete single packages.


#84

Well, apparently a close call but no harm done, thanks to a missing (imo a bit funny) flag in the command... heh


#85

Never said it did.. Only Linux mint completely and stupidly ruins everything


#86

Lols that would have gotten ugly.. See they make those flags long for a reason


#87

Hence why @MisteryAngel should use Ubuntu MATE to try the MATE desktop - as it's actually the MATE desktop as it should be not throw together to imitate another desktop.


#88

Alright let's chill that's off topic

Hmm I've made pretty amateur mistakes back when I started out.. I remember in the early days of x64 and x86 packages and multi arch.. I needed 32 bit libs on x64 system and wasn't paying attention to the Uninstall packages list and woops it Uninstalled a ton of the kde 3 desktop environment.. Was terrible.. Had to figure out each package that was Uninstalled.. Lols


#89

I once uninstalled half my OS because I wanted to remove the AMD graphics driver from the system, turns out that apt-get purge amd* is a VERY dangerous thing to do and then blindly hit “y” when it asks if you are sure.


#90

Needed a usb stick to install linux on another pc with, so did ‘cp /someiso.iso /dev/sdb’ instead of sdc which is my usb. Wiped a 3 TB drive.

Think everyone has done the ‘rm -rf’ fuckup one time or another, i did it in /

and there are more, so many more, first two months after i threw out Windows, think I installed linux on my workstation 30+ times, so much so that I setup tftp on my fileserver, so i could do PXE installation instead of USB.


#91

cleared the package cache because it was preventing something from installing.
then when it all went south, had nothing cached to roll back to…what version did I have installed before??
frantic searching then either

  • fixed so reboot didn’t hang
  • nuked system and started over

have done both several times

epic thread rez


#92

Find . -name “*.ISO” -exec mv {} game.iso ;

Was trying to rename .ISO GameCube games in their folders to game.iso to work with nintendont on a soft modded wii.

Instead of renaming each iso in their respective folders it moved each one a level up because that was the working dir and renamed each one game.iso

So each one overwrote the last game as game.iso until every folder was empty and whatever the last game copied was remained. Whoops


#93

be glad you weren’t working on one of the original hewlett packard xt systems!
they never provided any technical specs for those boards and you had to experiment with them to get them to work (and pray you dont burn the cpu or memory up)

anyhow my first linux goof was trying to install redhat 3 on an old system many years ago
hdd was too small and auto install function compressed everything on the drive during install.
what should have been a 1/2 hour install took 3 days to complete and i ended up with an unusable system
I hadn’t learned enough about linux at that time to correct it to run minimal install


#94

Sneaked a server into a classified in-mountain server park and connected it directly to the internet backbone in Sweden with the help of a friend who worked there. Then i hosted a couple of Swedens most popular Team Fortress 2 servers on it. We had the best ping of them all, this was around 2007.

The server was running Gentoo and one day, a couple of years later, I remotely connected and decided to update Gentoo. I managed to get a circular dependency during compilation… and then i rebooted…
So now, most probably, there is still a dark server running, stuck in boot, that no one dares to touch because no one knows what it does. Also my friend stopped working there so he couldn’t help.

It was a sad ending to our really popular TF2 servers.


#95

95-96 - I have for the fist time decided to install linux on my 386. It was Red Hat, at some point it was asking for password; and we (myself and my father) haven’t set any password, please do note we didn’t speak or understand english at all. We couldn’t figure out what was the password. (and we gave up on linux for quite a while.)

I revisited the old red hat install a year back, it was asking for provide a password for root (as to create new password, and then confirm it.)

rofl.


#96

Trying to unmount a filesystem that contained my current working directory…

linux - “yo you can’t do that”

me - “wtf why is BUSY WAT???”

oh… I’m a moron.


#97

Finding out the hard way that a login banner on an AIX system was sourced and not cat’ed

Users were instantly stuck in a mail program loop.


#98

I once did a rm -rf on the systemroot of the running system. That was kinda entertaining, SSDs can delete a lot of important stuff in a very short time.


#99

I was once installing Arch Linux, and had Packstrap(initial package install) fail so I went rm -rf /mnt to prepare to restart the install and then was oh, I still had the home partition mounted in mnt/home and my last backup of it was two weeks ago.


#100

Oh, I’ve done a dd if=./latest_linux_distro.iso of=/dev/sda bs=4M at least once.

I’m happy I’ve moved to NVMe. :stuck_out_tongue: