Return to Level1Techs.com

Dumbest/Funniest mistakes you have ever made on BSD/Linux/UNIX


#61

First realizing that nvidia drivers suck balls


#62

This wasn't MW, it was a friend, and it was on BSD not Linux, but we set the gigabit NIC to 10GBe instead of gigabit. Of course it was a pfSense router so once the LAN nic stopped working we basically couldn't access it, and he took 4 hours to figure out how to fix that

It was amusing to listen to over Skype with his phone


#63

LOLS well the title now says them all BSD Linux and Unix


#64

PFSense has some irritating issues with interfaces getting messed up and locking you out. I have six physical interfaces in mine and any time I swap one of the the cards out for something else it reorders the interfaces (unlike linux which keeps it's interface names, if you remove an interface in pfsense it will change the names of all the other interfaces).

The only way to fix it at that point to to tun through the initial set up again, with only WAN and LAN, then create all the optional interfaces again, in the correct order with the same names, and if you're lucky it will remember all your firewall rules.

I've had to do that more times then someone with the ability to learn from mistakes probably should have :P


#65

My serious mistake that I've made was using sudo rm -rf / and that was done on virtualbox, I've never do that again if it's my host system.


#66

Oh goodness yes. I remember when I was first beginning to mess with Linux and I did it on old PCs so I usually couldn't use a GUI (or it'd be so slug-slow it wasn't worth using) so permissions absolutely bewildered me. I really think the Tek team should make a video for Linux noobs explaining the Linux permissions system and how to deal with common issues


#67

is that the nvidia divideby0 edition?


#68

Running commands on a local machine, without noticing that my ssh connection had died. I cant exactly say how that ended, but it was worse than bad. Also had several cases of bash scripts that had less than ideal failure modes which ended up filling a disk recursively. The classic rm -rf has only really happened once with Secure Remove and a thunar custom action that should have asked for confirmation before being accidentaly mistaken for 'Find in this Folder'. Another was not really a Linux fail, more a human error.
Turns out that when given IP addresses of a router to test, you have to be really really raelly sure, it is the correct router and not the one handling an entire buildings access control systems. XD


#69

Trying to install Owncloud on a Bananapi that resulted in one gigantic piece of faliure.


#70

I'm using a laptop with Nvidia Optimus, I know this pain.
So far the beta driver SEEMS stable, but this whole no vsync is annoying as hell.

As far as breaking linux? Nothing too exciting, but the first distro I ever tried booted with no GUI and just dumped me at a terminal with no idea on how to use the thing. I was about 13 at the time.


#71

I run Linux(Debian unstable) on my tablet(Iconia W700), used to tripple-boot Android, Windows and Debian on it. I used to use gummieboot from the android-install as my bootloader, as it was properly configured for my tablet(Even though my tablet shipped with windows). One day, I decided to uninstall android to gain a little more free space(Only have a 64GB SSD in there :/). I paid attention to not deleting the boot partition, or any other Important partition, and even the resize of both, the linux and the Windows-partition worked just fine. Until one day I decided it was to much work to copy a kernel image + initrd to a different partition everytime I update. I thought using a script in apt or dpkg for this would be to much effort, and also quite a dirty solution. So I installed grub-efi. Everything worked fine, except that the volume keys and the power-button weren't mapped to the arrow keys as usual. This was to be excepted, they're volume keys, not arrow keys(My tablet has no physical keyboard, only a bluetooth one build into the case :/). I never really cared though, since the only other thing I could start by using those keys is windows, and I rarely use it on my tablet these days. I figured I could fix this issue when I need it(Never did it till this day lol). One day, I was theeming my installation. At one point in time, I also wanted to change grub's background image when booting. I unfortunately made the mistake to not have the partition mounted in grub when the image should be loaded. This lead to grub showing a file not found, press any key to continue promt. I did have any key, pressing the volume buttons actually brought me to the main menu, but the timeout was canceled anyway. So I couldn't even start Linux. Would be no problem if I were home, just plugin a USB keyboard, boot and revert the changes, but of course I weren't. I was on a camping trip with a few friends, who of course hadn't had any USB keyboards with them(). After the 3rd day or so without my tablet, I went to the next Internet cafe, and used one of their keyboards to fix my tablet.

tl;dr: I fucked with grub on a device with no physical keyboard, and the obvious happened.


#72

I did 'chmod 777 -R /' also.

It's probably a right of passage among linux users to screw up the permissions on their system after getting frustrated over "Permission Denied" errors.


#73

Didn't invested time in it long time ago, and had frustrations with Windows :).

Apart from that, there are a lot of dumb mistakes i made in Linux, it is really hard to choose one as an dumbest. Maybe this one: Forced V-Sync via fglrx during testing, forgot about it, and then wondered why flash doesn't work as it should, tried multiple browsers, environment commands etc. lol.


#74

Locked the root account with no sudo users.


#75

Didn't happen to me personally but a colleague of mine got a work Macbook about two years ago for development. He spent the entire evening setting everything up - Apache, MySQL, older version of PHP and all other work-related software. It took him until the small hours of the morning.
The next day he went to clear down a directory:
rm -rf /var --> permission denied
sudo rm -rf /var --> are you really sure?
Needless to say he was miffed. Didn't even get round to setting up Time Machine.


#76

Installing kde desktop ontop of a Gnome based distro.
No succes yet lol.


#77

Lols actually its simpler than one would think... ..

Just after the install in debian based distros run

Sudo dpkg - reconfigure gdm

Select gdm as main window manager so gnime can be happy and since kde can work with everything it wont complain.. Also if your on plasma 5.. Load gnome 3.14 or latest dev version since they both use wayland.. They will coexist better..

Worked for me on vm and on installed oses


#78

yeah i indeed needed to reconfigure gdm, but i decided not to botter with it anymore.
Because i dont realy like the new kde plasma desktop anyway.

I basicly like the classic Gnome shell, or Cinnamon.
which are basicly allmost the same.


#79

Id go ahead and install mate if you like gnome 2 alot however cinnamon is nice because its based on gtk3 and is more modern code with wonderful themes made for it...


#80

But Gnome 2 doesn't 'look like Windows XP' out of the box (not my words).

The Ubuntu MATE desktop has seen a lot of improvements in 15.04 though 14.04 is still the one to go for.

It's got loads of panel applets, more than a decade of themes and works with gtk3 themes and all.