Return to Level1Techs.com

Dumbest/Funniest mistakes you have ever made on BSD/Linux/UNIX


#41

Tried to purge an irritating application and used an asterisk in ubuntu... pretty much uninstalled everything lol. Since then I learned what not to do and now run arch as my daily os.

Also ubuntu screwed my partition table over once when I was patching graphics driver, but thats ubuntu's fault not mine. Overall I have had bad luck with ubuntu as it also has done other stupid things XD


#42

Had a MC and Gmod server running as root for a few months w/o noticing. Switched to root on the wrong screen session and didn't notice.


#43

Also had a drive that failed to mount once and I didn't notice, was downloading to a non-exsistant drive and didn't notice till I went looking for one of the downloads. Took a while to get that sorted out as I couldn't mount the drive till I moved the files that I had downloaded out of the drive that didn't exist. That was on Puppy 5.2 iirc. Fun times.

It had made a folder with the name of the drive where the drive was supposed to be mounted and they were in that folder, was pretty confusing trying to figure out why I could access the files on a HDD that wasn't mounted and refused too be.


#44

two things: Both of these are things I had to clean up from.
1. We used micro-drives in our casino machines. Think Compact Flash but with a really small 512mb spinning rust in it. We would lose these a lot because it was a really bad idea but they were marginally faster than the flash of the day, so...my tech is at a casino and one of the machines won't boot, I have him grab the drive out of a good one, bring it to the server room and make an image, turns out, he wrote it to the base OS drive on the server instead of to an image on the drive. (resulting in both of us driving back out to the casino to reinstall the server the next day.) [DD is awesome and SO dangerous.]
2. recently the company started switching development environments over to docker, but if you setup the install script and have an environment variable that is empty on the host OS, but you still include a / after the environment variable, then when you install Percona (mysql) it will chown 499.499 to your whole drive, such that it has permissions. The script was run as root. This was my home machine I had brought in to setup so I could work from home that weekend. Instead I got to reinstall the OS and thankfully it was a new install already so we didn't lose any data.

Fun times!


#45

Rendering unusable a usb stick by trying to mount a uefi partition on it...


#46

installed ubuntu. Ubuntu installer filled smart tables and locked out my hdds.


#47

We all have to start somewhere :)

They are some incredibly stupid mistakes to make. I was but a unworldly CS student in my first year at uni. I didn't actually know a hell of a lot about linux until I became a Gentoo maintainer and started Kernel development.


#48

I have an AUFS pool, and I tried to change the permissions for everything in the pool. Somehow the chmod command caused all the disks to be filled with duplicate files. By filled I mean 20 TB totally filled. Luckily my backup system generated a list of the new files and I was able to modify it in to a script to delete all the duplicates. But the thought of going through 20TB looking for duplicate files had sweating for a while :P


#49

@thirdmortal, When I first used Linux I broke Debian so many times it was unreal. I myself am a student. I'm just a little curious; how !much about Linux can you learn by compiling a Gentoo install? I have Manjaro on my laptop with git version of Linux 4.0 RC5 and I'm just curious about what one could learn on a Gentoo base that couldn't be compiling the kernel. I'm still very much quite a noob, I just now my around with bash and a few CLI tools.


#50

I don't think Gentoo helps you learn much besides "how to use Gentoo" to be honest.

Using linux or whatever isn't about knowing what every function does, or why something works the way it does, unless that becomes your day job.


#51

I remember one time changing the name of the superuser account to "oot" by accident on a production server running AIX. It took a while to figure out why we couldn't log back in as root on the console but could still "su -" with the correct password from another user account. Hilarity ensued once that was discovered.

And yes I've fallen victim to "rm -rf *" many, many times as you can tell by my forum name. "pwd" is probably my most used command now. ;)


#52

DD surely stands for DANGER DANGER!

I also fucked up moving an iso to a USB thumbdrive

dd if=/whatever/distro.iso of=/dev/sdb

sdb was my /home drive

found out when I went to the other machine, didn't boot off the USB, came back and my desktop was blank (no icons, plain green wallpaper).


#53

@Dexter_Kane (OFF TOPIC) You should have found a friend who was grandfathered unlimited on verizon and made sure he had a good 4G connection and trolled them with a 20 TB download in spite of bandwith caps.. Nah im joking thats just uncalled for haha

Yeah I wouldnt sort through 20 tb good thing you could make a script to undo it


#54

this happened to me once, but I had a ls -alR with paths from the top of the mount point as a catalog of all the files (I like to have those kinds of things, they are handy)
wrote a script to go back and fix the permissions by looking at the text in the text file. that was not a good day. was like 85,000 files.


#55

Permissions are probably one of the easiest things to make stuff go horribly wrong in linux.. I was helping a guy the other day and he somehow managed to make sure dpkg had zero permissions for anything and I ended up just telling him to reinstall because he did not feel like figuring out how to get it back to all the permissions it needed.. I offered to help but he was like
PHHHHssshhh thats over my head haha.. Which was totally fine because he gave another distro a try and realized he shouldnt listen to distro trolls/Hipsters..

I ended up PMing him how to give all the permissions back to the package manager if he ever needed it again :D


#56

HAHAAHA.. Im sorry I have to laugh because I have made those mistakes.. took me a while the first time but figured out how to get all my KDE settings back onto my home partition.. good thing Home was seperate so the system was still workable !
:D


#57

I remember when "fix permissions" apps on android would just rek everything. It was the recommended fix for everything by forum warriors with no clue.
And I remember the first time I plugged in a USB into Arch and had to find a crash course in mounting. "WTF is all this sbd / sbd1 business? The tutorial say to mount hdd1!"
I did another dd funny the other day trying burn a MacOS recovery iso to a thumbdrive. I grabbed sdb1 instead of sdb, wouldn't boot from the drive till I realized what I did. Eventually got it figured out, but I still told them to at least run Linux on it.


#58

I once deleted my home folder, thinking I changed directory to some other directory I wanted to do my cleaning.

I was all like "rm -rf *" Then I went "FUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUU" since I noticed my directory where I executed that...

I flipped a table out of anger that day.


#59
  1. I have locked myself out of systemd still not sure how I did that. fixed it by rolling back to a previous btrfs snapshot
  2. I was drunk during a kernel update in Sabayon and turned off the machine, borked everything.
  3. I shredded my /home drive thinking it was a USB drive.

#60

I made the mistake of updating Arch and it broke my xorg.
But its ok i could fix that fine and updating hasnt broke anything since then.

I havent made too many mistakes, partitioned wrong a few times or messed up a grub install, but those are all at install time so it doesnt really matter