Driver problems Win 10 and ASUS MB

Hi there

I am currently working on a ITX system for my Oculus. As my budget is tight I decided to use used hardware that I can find cheap.

My system

CPU: Intel Core i5 4590

Now I have build the system I am trying to install Windows 10 but it dose not work.

I have done this many times and I think I know what I am doing.

  1. I created a bootable USB-stick using the MS media creation tool.
  2. I pluged the USB into the new system
  3. Start the system and choose the USB in the boot settings.
  4. Run the installer.

-> now so far so good, but there seems to be a driver issue, not letting me run the Installer.

I googled the error and came across a hint to plug my USB into a USB 2 port, I have tried this but It doesn’t work. (I can also use a USB 3 port at any other machine so I think this is no longer a problem)
So I googled more and tried to get the Intel Rapid Storage Technology ( drivers. -> “The drivers are not comparable with your system”

I don’t know what to do.
Can someone help?



What’s the specific error? What ssd are you using?

I guess ssd doesn’t matter. When I saw the intel page and saw optane, I thought that was the reason it wasn’t running as optane requires newer cpus.


whats the actual error? what do you see?

I am not getting that far in the installer, I am planing to use a Toshiba TR200 SSD and some old 1TB Samsung HD. I have tried to unplug both SATA devices but It didn’t change anything. The error is the one shown here: I have tried everything he dose but nothing changed

1 Like

Well, I’m honestly not very familiar with Intel chipsets but that’s a fairly old one (5 yrs) that is only PCIe 2.0 according to intel’s ark. I wouldn’t be surprised if MS didn’t make room for drivers for it or they culled them from the ISO at some point. You may need to extract the SATA drivers from whatever archive they come in so that you have a directory with the inf and loose driver files on a USB stick. Then you should be able to load them during setup (in past windows versions you had to hit F6 to load storage drivers when it was starting up).

Absolute worst case you’d have to slipstream all the drivers you need into a custom Win10 iso. I assume that’s something that can still be done. It was an option with Win7.

Another alternative is to get a cheap SATA pcie card to connect your 2 drives to. You could at least get installed with it assuming it has Win10 drivers. Of course that’s assuming the SATA controller is the issue.

If it’s a used board you might reset the bios and start from a fresh setup just in case they were using onboard RAID or something before.

Haswell is pcie 3.0

There should be no issues with the sata drivers. There might be issues with the USB though.

@Janick I need to know your exact error. Take a picture of the screen.

My bad. Usually the installer should only care about either USB or SATA drivers, combined with the Ark page for that chipset I thought maybe. /shrug.

Could be an outdated ISO? You have the one released just a few days ago? Well rather than outdated it might just be an issue with the installer itself that has since been fixed.

The thing is, I am installing Windows in German (I am Swiss :wink: ) so the error is in German.

No I just renewed it with the same result and anyway it should not matter with that old hardware .

Yeah It is probably a USB issue, but I can’t explane why It works on my Ryzen 7 2700 build but not with this old hardware, considuring I tried almost every USB port. (I even used an other case with USB 2 header to be sure that It is USB 2, as my case only has USB 3 header)

Have you tried using the USB ports on the mobo and not ones thru the header?

Es ist gut mann kann deutsche sprechen.

Reset the cmos back to default and try again. Its acting as if you have a raid setup almost.

1 Like

Tried like 5 back IO and both of the front IO

1 Like

ah top :slight_smile:

1 Like

will do

lol, someone’s too busy pointing out I’m a noob on intel hardware to see that I already suggested resetting the bios :stuck_out_tongue:

Doesnt mean it was done. We dont have to make a pissing contest out of it. Its the right call at this moment in time.

Still same result

/shrug. I just found it funny. If anyone was making it into a contest I thought it was you. I don’t really care.