DP repeater doesn't quite emulate monitor

Win10 20H2 w/ GTX 1060 GPU
Dell U3145W through KVM, Dell U2717D direct
Monoprice cables - probably all DP1.4 rated but definitely at least 1.2.

I’ve got a L1T DP1.2 KVM, and a Windows 10 PC hooked up to it via the L1T DP repeater/EDID cloner. I have the latter to prevent Windows from rearranging windows when I switch computers; the cables are 3m at most so I don’t need the repeater functionality.

I’ve tried both autolearning and copy functions; what seems to happen either way is that when the monitors are in power-saving mode and I wiggle the mouse, the KVM-attached display does not wake up and the repeater flashes green. I can push the function button on the repeater to force a hot-plug event, but then of course the windows get rearranged. The slide switch is set to “P” (which matches the label on the DP output) and the HDMI output is unconnected.

Is there something I can do to make the repeater behave as I expected it to?

Emailing the support email is the quickest way to get help…


@MrMorden The advice @nx2l gives sounds good, and I hope that the support team can resolve your issue. Please share it with us if they do! I have a similar HW setup, and am interested in chatting about the quirks we see in this gear. I am generally satisfied with the DP EDID function, but am hoping @wendell will come up with an improved version that works even better.

I like the title you chose: “doesn’t quite emulate monitor”; I agree - it’s close, but not quite the same. However, my experience is a little different from yours. In general, my Windows display does not rearrange the secondary display when I switch away and then back. I haven’t noticed an issue with power-saving mode, perhaps because mine is set to rarely activate. (Based on poor experiences in the past, not related to the KVM or DP repeater.) In addition, I have turned off the deep-powersave modes built in to both my monitors because they gave me fits, even with the monitor cabled directly to the computer.

Care to say more about which power-saving you refer to (Windows? Monitor built-in?) and how you have it set up? I would probably do an experiment to see if my results are similar.

When my monitor does fail to become active after switching the KVM to it, or similar, I generally try switching the KVM to another monitor and then back, which usually fixes things up. I suppose you’ve tried that…

I invite your attention to the following thread for some further discussion of quirks. So far, everyone’s experience seems a little different, but “waking up after switching or sleeping” seems like common ground.

Best of luck getting your system working to your satisfaction.

1 Like

hook up the monitor directly to the repeater and that to the computer. Press and hold the button for 4 seconds. once the repeater settles down you can hook it up in line with the kvm. Don’'t press the button again and see if that behaves more like you expect.


Thanks for the reply, and I hope it helps the OP.

As for me, yesterday it dawned on me that some “surprising, quirky” behavior was actually correct operation - just not what I (incorrectly) expected. As of now, I don’t know of any “quirks” with the DP Repeater, and am even more satisfied than I was before.

I have some excuse for my misunderstanding since the behavior in question takes place when a monitor is switched away or screen-blanked, so there isn’t any way to see what’s happening.

This procedure helps at least some of the time - had one failure where I had to press the hot-plug button but it’s a lot more reliable now.

This topic was automatically closed 273 days after the last reply. New replies are no longer allowed.