[DONE (again)] Ryzen vs. U̶b̶u̶n̶t̶u̶ F̶E̶D̶O̶R̶A̶ Ubuntu

tried pulling the cmos battery, tried putting in an AMD gpu. no change.

tried windows 10; it was not even able to start. BSOD:
- internal power error
- kmode exception not handled
- unexpected kernel mode trap
- system thread exception not handled

…and after researching these a bit, seems it might be due to bad AMD graphics drivers in windows. so i guess I'll switch out the card again and try with the 1050 ti.

: /

How are you getting on with this?

Yesterday I found leaving "firefox" idle for a couple of minutes (without any web page loaded) would hard-lock my Ryzen 7 1800x system in Slackware Linux-current, with 4.10.15 kernel. My system has a RX480 GPU installed.

It'll sit idle for ever without firefox running, and will sit idle with Konqueror running. Seems to be just firefox.

[I've "fixed" it today by trying to install the AMDGPU-PRO driver (which failed), and then removing it. Because of how Slackware works, this should have left a broken graphics stack. The expectation is one should re-install all the dependant packages (X, mesa, etc) - but I haven't, and it's working for now...]

There are a few reports out there of idle lockups / hangs on Ryzen.

k, update:

turns out my issues * may * (fingers crossed) have been purely physical (mechanical?). apparently, there was a glob of thermal paste which squeezed out from under the cpu cooler and eventually worked its way into the socket. my last resort was the take it apart, and that's what I found. :confounded:


I cleaned the cpu and the socket repeatedly for three days. then I waited another two days to see if I came to realize anything else idiotic I might have done. then I put it back together.

so, again, fingers crossed. but it seems stable now. I have the overclock applied again, and the GTX 1050 ti is running fine. back to ubuntu 16.04, with the kernel upgraded to 4.10. still only the nvme drive installed for now.

I ran stress-ng for 6 hours earlier, along with glmark2 and heaven. currently, started up stress-ng again and left it to run overnight with chrome and firefox open doing various things (did you know there's a ten-hour nyan cat video on youtube?).

will report again tomorrow night. wish me luck!


Thats just ubuntu dude.

1 Like

sleeping / hibernating is not working. doesn't wake form hibernation; wakes from sleep but windows have huge semi-transparent white border around them :frowning:

upgrading ubuntu to 4.11 broke very badly (boots, but won't log in successfully).

trying fedora 26 again, and maybe arch.

all RIGHT; Fedora 26 with new latest nvidia driver (381.22) is working, seems stable, AND sleeps!
AND wakes up again with no apparent issues!

for some reason, the fedora installer made a swap partition only half the size of my ram, so that's what i'll fix tomorrow and see if i can get hibernate working. then start installing programs and maybe by the end of the week i'll try doing work on it.

1 Like

You the man dude.

I was all ready to declare this build a success…

Then i tried to replace the side panel. :unamused:

I'm re-using the case and cpu cooler (hyper 212 evo) from my previous machine. However, it seems that a Ryzen motherboard + AM4 socket + CPU is roughly 8-12mm taller than my previous, Haswell-based "stack" (pun intended).

The case side panel hits the tops of the 212's heatpipes.

» sigh «

I am calling it DONE (for now).
Thanks, everyone, for the support and suggestions!


That's beautiful. I'm happy you got that triple monitor setup going. Gives me hope for my upgrade build/rebuild. F26 although being a Alpha build could have bugs, but report back with your experience.

1 Like

main thing to work through right now is disks.

fedora uses LVM, which I am not terribly familiar/comfortable with. I've been trying to add a few disks, but everything I can find is focused on adding drives to a volume: this is exactly not what I want. I want the new drives to have specific paths, so they're clearly segregated from the boot drive. This is both for performance reasons (i.e., these SSDs are much slower than my nvme drive, so I want to keep certain files in certain places), and also because I need to be able to just unmount and physically remove the drives and take them out with me, from time to time.

normally, I'd just add entries for them in fstab. but this seems to cause breakage with LVM.

: (

Why did you choose LVM, I just use 'Standard Partition' for configuring my Hard disk. You can make those changes if you choose Configure my Own disk before install. Im on F25. I know there is a way around your issue though

everyone said it would be easier?
TBH I wasn't really focused on that, at the time. I just let Fedora install, mostly with whatever defaults it wanted. I may re-install, but that's probably not going to be for a while; I want to get things ironed out first. I want to use this machine. :slight_smile:

This is nutso. Just having disks connected at boot is breaking things. If i disconnect them (e.g., unplug the sata power cable) everything's fine. If any or all are connected, I get the fedora logo, but it eventually hangs or drops me into emergency mode.

: (

Maybe I'll have to try re-installing sooner than I thought.

down the rabbithole I go again... although I havent used fedora recently as I'm on a 2011 macbook and all kernels that are available to me on it dont work with wifi. I'll give this a go and hope for the best.

When I first installed f25 with kernel 4.8 it was a royal mess with AMDGPU. But a sudo dnf update got it in a good good space with the kernel 4.10 versions and I'm still fedora myself.

Ryzen well asus motherboards. I been killing them.. No idea why.

1 Like

Yeah, I've been keeping up with updates. This morning brought a kernel update, which I will be installing shortly.

Also, ooOOhh fingers crossed

- Improved memory compatibility.
- Fixed PCIe Hot-plug function issue.

so, SOMEHOW i ended up with the v4 bios (+1), Fedora 25 (-1), and kernel 4.12 (+1).

Also figured out the disks problem, I think. I kept Fedora 26 on the nvme drive, and installed 25 on a regular SSD. In the attempt, the F25 installer kept crashing, and eventually told me it was because, among the disks I had connected, there were * two * LVM's with the same name ("Fedora" - left over from previous install attempts). Wiped those, and the syncing error seems to have gone away.

This is feeling a lot more stable. Over the past couple days, doing actual work on this machine, things had been shaky, with occasional program crashes/misbehavior, one actual lockup, and a surprise reboot. I'm also putting a lot less effort into installing packages, dependencies, and the whole "just working" end of things.

So I'll go a few days with this, and see how it works out.


Are you still going with LVM? Is it important to do so? I've always manual config'd my Fedora installs from anaconda (the installer) Luks partitions /ext4 /xfs and even dual boots. Maybe have a look if you can...

1 Like

Tried overclocking again back to 3.85 after F26?

1 Like