[DONE (again)] Ryzen vs. U̶b̶u̶n̶t̶u̶ F̶E̶D̶O̶R̶A̶ Ubuntu


Ryzen 7 1700 @3.0GHz
32GB (2×16) G.Skill Fortis DDR4 2400
MSI B350 Mate
Ubuntu 16.04 (Xenial)

I’m having a difficult time with Ryzen. Initially, things went very well — I got an overclock of 3.85 GHz which remained stable during 24 hours of stress-ng testing, and another 24 hours of memtest86. (Note, I have since restored the system to stock speeds.)

However, problems started surfacing when I transitioned to more “everyday” tasks, such as web browsing, installing programs, turning on my other two monitors.

System still reaches POST fine, but linux crashes very frequently. Some symptoms:

  • ubuntu hangs before login screen if additional disks are connected.

  • ubuntu disk encryption hangs on disk password screen.
    if i boot in recovery mode, i can successfully enter the password and start a session, but it is very unstable. i have since re-installed without disk encryption.

  • random blackouts and restarts.

  • hibernation and sleep don’t work.
    hibernation flashes some messages on the screen (couldn’t catch what they said), and upon waking, there is major artifacting around windows.
    sleeping seems to work, but when waking, crashes and restarts upon reaching the desktop.

I’ve read about Ryzen not liking older kernels, so I’ve updated to kernel 4.10. This seems more stable, but still qualifies as “unusable” for actual work.

I’m going to go back to this for a few hours tonight. Any suggestions for what to try / what info to collect for troubleshooting would be appreciated.

If you're in a phase where you can just test things put on Fedora 26 beta and see how that fairs. It's on Linux 4.11 and has all the latest graphics stacks, etc.



couldn't even get the live image to start. going to try re-burning the iso.

I'd recommend booting from a USB stick instead of a DVD. You avoid all the issues of unreadable/corrupt optical media.

It's how I installed Slackware-current onto my Ryzen 7 workstation. That was an uphill struggle because I wanted mdraid, LVM and an nvme boot device.

sorry, wasn't clear. Yes, i'm booting from a USB stick.

what troubles did you have with your nvme drive? mine seems to be working ok, but plugging in other drives is flakey.

I had the exact problem with my Ryzen setup as well, could not get F26 installed. F25 works though

ok — looks like it was just a bad burn. but now i'm getting an unending stream of "printk messages dropped"

Thats fedora 25 on Linux 4.8..

You want this https://getfedora.org/en/workstation/prerelease/


downloading now.

yeah, tried again and got a kernel panic.

it's frustrating that this was working just fine. right up until i decided it was ready.

: /

1 Like

Is your motherboard up to date with firmware

yep. 7A34vA3

NMI Watchdog: Watchdog detected hard LOCKUP on cpu 4

is good news?

fedora 26 is installed, but trying to get the nvidia drivers installed keeps failing. if i try to register the kernel module with DKMS, it kernel panics or gives a "failed to install" message. without registering with DKMS, it fails to install the DRM module. uninstalling and trying again dumps me into emergency mode.


and somehow my home directory is gone now??

guess it's time to re-install.


at what point should I start wondering if this is bad hardware?

thanks, everyone, for responses so far. this has been a very sad week.

To test the hardware you could try a distro that has the drivers and such to hand without resorting to the command line and runs 4.10 kernel. A little less edgy, maybe Ubuntu 17.04 or a rolling release like PCLinuxOS. God forbid just as a test install Windows 10 just to see if everything is working hardware wise.

1 Like

The Nvidia drivers have some problems with the 4.1x kernels. Which version of the nvidia driver are you using?

Probably not good news. Google gives a few fixes. None specifially for Ryzen, but might be worth a try:
1) Update BIOS
2) Disable VT-d
3) Add "clocksource=tsc" to the kernel command line.

...anyhow, it's not necessarily an indication of bad hardware.

Do you have a non Nvidia graphics card you could try?

Ah, they were to do with issues in the Slackware installer. It was fixed/patched about a week ago, just after I'd figured out a work-around. The installer was blindly taking the first 3 characters of the boot device (eg "sda") and appending a partition number (eg 1) - that clearly doesn't work for devices with long names like nvme0n1p1.

If you're having this level of trouble there's a hardware issue.

Are you using a new proper PSU or some old junker? I assume/hope it's a new one.
There's been quite some issue with people running Ryzen boards with old unstable PSU's getting no posts/severe instability.

I also assume it's not overclocked or anything.
As a last resort try running windows off a USB or something, if that doesn't work you have certainly got hardware issues.

As for this:

You can try setting your CPU to something like 2.2Ghz at 0.9V fixed and see if it's stable then. It might be XFR or other power related issues causing that problem. Using a low fixed clockspeed without CPU scaling should prevent that.

suppose i could try that. :confused:

375.66 (i have a 1050 ti)

1) already most current
2) i do NOT consider this a "fix"
3) will try


brand new evga 850 g3

it was, and i returned it to stock settings when these troubles began. hasn't seen an improvement, though.

well, as above, I would not consider this a "fix." if this "worked," then i would consider the cpu "broken." completely stable on all cores, with all features, at an absolute minimum of stock speeds or it's fucking broken.

Thanks for all the input, guys. Will be trying out these suggestions tonight.


There's been an odd BIOS bug with Ryzen boards, atleast in the early versions.
Did you recently try a full Clear CMOS and unplug the system?
I found that sometimes on early ASRock boards the overclock voltages got 'stuck' when trying to revert to default settings normally and would cause some weird behaviour. Don't know if MSI also had that issue.

Personally I'm using an ASRock X370 Gaming K4 with Ryzen 1700X 3.8Ghz P-State OC and 4Dimms of 32Gb at 2666Mhz right now.
All under Arch Linux without any issues. Only getting kernel 4.11 for the ALC1220 sound chipset was a bit annoying.

no. will try that tonight. the board reports the expected (stock) voltages/clock speed, though. and when i was working on the overclock, those numbers updated as expected with each change.