Displayport deep sleep and LG monitors

I have gotten a new LG monitor (27GN800-B) to replace my main monitor in my dual monitor setup, and it is a very nice upgrade from my admittedly very old monitor. However, there is one problem that I have discovered with this monitor: Whenever Windows puts the display to sleep it disconnects the monitor, causing windows, and icons to get shuffled. From my research this doesn’t seem to be an isolated problem with just this monitor or even LG monitors as a whole, it’s a problem with a lot of DisplayPort monitors. The best solution seems to be to go into the settings in the monitor and disable DP deep sleep, but my new monitor doesn’t seem to have that option. The next best workaround seems to be set windows to never sleep the monitors which will avoid the problem.

Is there another solution that I don’t know about? Any help would be appreciated.

Is this specific to DP? I imagine power efficiency requirements would force HDMI to have something similar…

I have seen mention of deep sleep for HDMI in ASUS monitors, but I haven’t seen it anywhere else.

Look for the powers setting is your monitor. You may see it as Energy Saver or Energy Star.

On My LG monitor, the power settings are in the Display Setting menu → Energy Saver → Toggle it on or Off.

I am using HDMI though and not DP, because my Monitor only supports HDMI, DVI-i

Under my Energy savings setting I have High, low, and off. The description says “conserve energy by using luminance compensation algorithm”.

I have tried turning it off and that had no effect.

Bummer. What is your GPU? Maybe you can turn the setting off in the GPU driver.

I have a 3070. I haven’t found anything relevant in Nvidia control panel, or Nvidia experience.

I am a GNU/Linux user and I run team Red hardware. So i can’t really help much, unfortunately.

I found this though which seems that you may be able to get this beta fix from MS on Windows 10.

Interesting, seems like that feature is currently in windows 11.

resistance to the upgrade intensifies

Try software - persistent windows

It might help. LGs displayport team has checked out a while ago.

2 Likes

I have had the same issue with my LG for years. I was excited about the Windows feature @Mastic_Warrior mentioned, but I don’t know if it will get pushed to Windows 10 as it seems MS decided to make that a selling point for Win11.

Maybe I’ll give this PersistentWindows thing that Wendell mentioned a try

1 Like

I’ll give it a try since it seems like my best hope besides returning this monitor and getting one that can disable dp deep sleep.

i stopped trying to fix this issue. and just use
winkey+p
and select extend.
i leave the lg on standby so when i select 2 screen mode it just pops up…
but…
any icons from the mane desktop, placed on the extended screen will go to there previous location if i switch to single screen mode. end result i dont move icons to the second screen :frowning:

it would be nice if the multi desktop flipper could be changed to show the second desktop on the other screen. but nope. if you switch desktops both screens switch.