Return to

DirectX 11 - DX Web Installer says i'm up to date

So i’m trying to get 2010 Aliens VS Predator to run in Direct X 11 mode and I used the DX Web Installer from Microsoft and after running it determines it’s up to date and no installation is necessary. I’m on Windows 10. Of course, running DX 12 on a modern GPU. It worked fine before I upgraded to Windows 10 from my W7 installation. Could there be something going on there? Currently on W10 Pro 64-Bit.

Uh if I’m not completely retarded right now DX11 doesn’t need to be installed, it comes with the system just like DX12.

Have you tried any other DX11 games yet? Might be just an AvP issue?

That’s kind of what I figured. I thought it was “backwards compatible” in a sense. I was told to install DX11. I’m not sure what to do now. I’ve Googled this issue for others quite a bit. Surprisingly it doesn’t show that many people having the issue with W10. People actually had the Issue on W7. Odd.

If that particular game is from 2010,
would it even work on windows10 then?
Maybe you are missing certain DX11 dll liberary´s.

Have you tried running it in compatibility mode? (yes, lol - but right click the exe and set some compatibility mode settings for say windows XP SP2/SP3 or Windows 7).

It could be that it is looking for some specific version of one or more DX11 libraries, and compatibility mode will intercept that and tell it the version it is looking for instead of some more recent version.

IIRC (and again, I might be wrong here) W7 only came with DX10 and 11 was added later with one of the service packs or through manual install, so that might be the issues you found.

DX12 and 11 are not compatible with one another, they are installed alongside each other.

But yeah if you have any other DX11 titles check if those work to see whether it’s a general DX issue or a game-specific one.

You might need d3d??.dll or simillar to run that game, Diablo 3 on win 10 64bit required some odd .dll to run it good.

You might also look for someone else that own that game on Steam (assuming you don’t) and get the first tile initialisation files that typically install all the DX and visual basic run times and so on. It might need something from one of those.

Verified game cache on Steam, nothing. Set compatibility mode on all three .exe’s to Windows 7, then windows 8. Nope.


May sound like a stupid suggestion, but did you try turning it off and on again uninstalling the game from steam and re-installing it?

Did you try a different DX11 game yet?

Tried that twice. Once after reinstalling drivers. I played FEAR 3. Back when I had Windows 7 installed. I still play GTA V on the same installation from when I was on 7 then switched over to 10. It was seamless. No problems. Fallout 4 is apparently another DX 11 game. No problems there. Yeah it’s just AVP having problems. For some reason though I suspect it’s my graphics drivers? Or maybe i’m jumping to conclusions. I uninstalled my GPU drivers and then my display had a crazy green tint. I downloaded and installed new drivers, and as they were installing the tint went away instantly.

Still didn’t fix my issue, though. All games I play run fine. In fact, I noticed a bump in performance for some games.

If it is just one game then I wouldn’t think it’s DirectX since that comes with the system, it’s not like it used to be where every game needed a different version installed separately…