Did one of my RAM sticks die?

Hey everyone. I've got about a 1 week old Ryzen build and I believe one of my RAM sticks have gone bad but I'm not sure. The RAM I have is the G.Skill TridentZ RGB RAM 2x8GB Sticks @ 3200mhz. I haven't overclocked or anything and I have the most up-to-date bios. What happened was I was playing Player Unknowns Battle Grounds and all of a sudden the performance got worse, the game was all choppy and skippy, and it wasn't just FPS. The PC would kind of hard lock for half a second or so every couple seconds. I restarted my pc only to find a black screen and it wouldnt post or boot to windows. I took one stick out and it worked fine. But the other stick in alone and the problem persisted. I assume one of my sticks just died but I'm not sure. There is an error code on my MOBO (Gigabyte AX370-Gaming K7) which said 65 but when I looked it up it said it was an issues with PS/2 ports, which I don't have anything plugged into. I tried memtest but I can't get the system to even post with both sticks in so I don't think I can test them both. I'm willing to purchase another set of RAM and return this, but before I do is there any superior RAM for Ryzen? My research showed my current set being good but I was wondering if there are any superior sets? Thanks for any help in advanced :~) (P.S The RGB LED on the broken RAM stick works, if that matters.)

Full system specs:
CPU: Ryzen 7 1700 w/ NZXT Kraken
MOBO: Gigabyte AX370-Gaming K7
RAM: G.SKILL TridentZ RGB Series 16GB (2 x 8GB) 288-Pin DDR43200MHz
GPU: EVGA 980 SC
SSD: 500GB Samsung evo SSD
HHD: Seagate Baracuda 1TB
Lighting: NZXT Hue+
OS: Windows 10 64-bit
CASE: NZXT 340 Elite
FANS: NZXT aer RGB fans (Both the MOBO and CAM lighting software conflict with the RAM RGB lighting software)

try different ports and use http://www.memtest.org/ for a hour or so each per stick with only one stick in. odds are one of your motherboard slots died over the stick itself.

2 Likes

couple of things you can try

downclock your ram. 3200 is not 100% stable on ryzen yet.
Reseat all of the ram modules.
reset the cmos
try the ram in different ports

2 Likes

I've tried all ports. It's got to be the RAM stick. Can't mem test because the system won't even post if the bad RAM stick is in. Just sits at a black screen

I believe the RAM goes to 2100 automatically, as thats what it said in the BIOS when I first built. I didn't up it at all knowing Ryzen had RAM issues. I tried reseting the cmos but no success. Also tried all of the slots :[

ok rma time

1 Like

yep RMA time

Know of any superior brands/sticks of RAM I should look at?

the gskill trident stuff is really good man. other then that gskill released some ryzen specific ram recently that can clock 3600~ on ryzen. https://www.gskill.com/en/press/view/g-skill-announces-flare-x-series-and-fortis-series-ddr4-memory-for-amd-ryzen
the corsair stuff is generally overpriced, and kingston makes good cheap stuff but not a lot of high end.

This is very much the behavior you can expect if your RAM fails/becomes unstable and needs to reread multiple times to retrieve data until it finally hits a critical code page that's not retrievable and hard locks.

It's amazing that your system worked as it did honestly.

1 Like

It's not really going to help the original question, but keep in mind that the current version at memtest.org is not DDR4 compatible. However, there is a commercial continuation of the memtest86 project which also offers a limited free edition, that I used before which works nicely with DDR4 and also DDR4 ECC RAM.

On a side note, that tool was the only way for me to verify that ECC was working on my Skylake NAS. :wink:

1 Like